[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

debian installation problem: AT keyboard detection with ASUS-A7A266,

This would be my first address to the debian-user mailing list, and I
did as thorough of a search as I could manage before posting my

I'm currently running into a problem with installing debian with my ASUS
A7A266 motherboard regarding an "AT Keyboard not present" error.  My
current RedHat 7.2 installation behave(s|d) normally during installation
and typical use, and so I never noticed a problem before.

Now I've been enticed into trying out debian, and I've found that the
installation process cannot detect my keyboard. (I'm assuming based on
the research that I've done it has something to do with the ps/2
controller and the linux kernel).

Building a new kernel for RedHat allowed me to recreate the problem. 
However the USB module came in, allowing me to continue with my regular
use as desired.   I think this means that there may have been a patch
applied to the kernel source used for the RedHat installation/default
kernel that cleared up the problem with the ps/2 controller.  But I
really don't know enough about what I'm doing to find out what, if any,
patch was used.

I've been monitoring the mailing list archives, and googling for
solutions just about every day for a couple weeks, but there doesn't
seem to be any new developments on the issue.  (There was a mention of a
clocksync problem with the a7a266, fixed in an ac patch... a person or
two had this AT Keyboard not found error, but then solved an unrelated
problem that took care of their keyboard detection error as well...
their solution would not work for me to solve my particular problem.)

Seeing as this may be a problem directly relating to a flakey
motherboard (it seems that the a7a266 and related boards were probably
just a intermediate product for ASUS using the ALi chipset, they
followed it up shortly with a line that used the more revered AMD
chipset), I was hoping to get around this problem by just compiling a
kernel with USB support built in and using that kernel with an
installation disk.

I attempted to do this using the rescue disk a number of times, but was
unsuccessful.  On what I consider my closest attempt, I had the rescue
disk booting with my customized kernel, my USB keyboard was working
great, I was loading the ramdisk image for the root filesystem from the
other floppy successfully, but alas... it couldn't find init.  The error
was something along the those lines, followed by a suggestion to pass
INIT= argument to the kernel.  I'm not educated enough in exactly what
is happening here to have an intelligent guess as to what to complete
that argument with, other than the default locations (which I would
assume don't since the kernel looks in the default locations).

I believe I'm attributing this failure to either a misconfigured kernel,
or perhaps some issues with a root.bin filesystem image that didn't
conform to some changes made with the newer kernel that I was
compiling.  In that vein, I tried to compile a kernel of the same
version number as the install disks, and the same error occured.

If anyone has any suggestions to solve my problem, I would greatly
appreciate it.  At the current time, purchasing a different motherboard
is not an option for me (regretfully)... so while motherboard
suggestions will be accepted graciously, they will not solve my problem
in the near future.  Further explaination on the rescue disk
customization process is welcome as well, although I am not lazy, and I
have read all of the documentation and relavent how-to's and literature
that I could get my hands on (not to say that there isn't more that I
missed, of course).  Finally, if someone can provide an installation
process for me with USB support, I would be eternally greatful (net-inst
cd, rescue.bin/root.bin, mini-howto... etc).

If there is any more relavent information that would assist anyone in
disecting my problem, please let me know and I will be happy to provide.

Thank you for your time,

Travis Bradshaw

To UNSUBSCRIBE, email to debian-user-request@lists.debian.org 
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

Reply to: