[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Help -- Scanner problem with MAKEDEV

On Sat, 23 Mar 2002, Cam Ellison wrote:

> I am trying to install an Epson 1650 (USB) scanner.  Sane is installed, everything is plugged in, but I cannot get MAKEDEV to do its thing.  I have added a /usb directory to /dev, and run "mknod scanner0 c 180 48" by itself and in company with MAKEDEV (as MAKEDEV scanner || mknod scanner0 c 180 48).  mknod installs scanner0 OK, but I still get nowhere with MAKEDEV, which I think should complain that the device is already created.
> sane-find-scanner says "failed to open (status 4)"
> I have been through Google, the MAKEDEV manual is out of date and not useful, and I am starting to tear out what hair I have left.  
> I have usb enabled in the kernel, as well as usb scanner support, and both ohci and uhci set as modules.  I have not tried to insmod them, though since I have an ALi chipset, I think uhci won't do anything.
> /proc/bus/usb/devices does not exist -- there should be something there.
i also have this exact problem.. but on a r/h machine.

first, you have to be able to load a bunch of modules:

alias char-major0180 usb-uhci
pre-install usb-uhci
alias usb-controller usb-uhci
options scanner vendor=0x04B8 product=0x0110

the options line above is for the epson 1650.

if there is no /proc/bus/usb/devices, then you are missing usb support in 
your kernel.. the first three lines above will do that as long as there is 
usb support there.

if you get this far, watch the dmesg for the usb detection and startup:

usb-uhci.c: USB UHCI at I/O 0xd400, IRQ 9
usb-uhci.c: Detected 2 ports
usb.c: new USB bus registered, assigned bus number 1
hub.c: USB hub found
hub.c: 2 ports detected
usb-uhci.c: v1.251:USB Universal Host Controller Interface driver
hub.c: USB new device connect on bus1/2, assigned device number 2
usb.c: USB device 2 (vend/prod 0x4b8/0x110) is not claimed by any active 

now you will have arrived at the problem i have, which is visible in the 
last line of the above.  it was working perfectly just before a recent 
upgrade of the kernel (a minor 2.4.xx) and then it stopped..

xsane (which was working perfectly) will report that it can't find any 

one of the reasons i came to debian was to get more control over my 
software as illustrated above.  not there yet.

i will get back to this problem as soon as i have woody stabilized.

keep in touch


Dave Mallery, K5EN  (r/h 7.2 krud; debian woody+ximian)
PO Box 520
Ramah,  NM  87321

no gates                     .~.
  no windows...              /V\
                            /( )\
running GNU/Linux           ^^-^^  (Linux TM Linus Torvalds)
  free at last!

To UNSUBSCRIBE, email to debian-user-request@lists.debian.org 
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

Reply to: