[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: partition does not end on cylinder boundary error. FIXED

Hi Sebastian,

On Tue, 2002-02-19 at 20:52, Sebastiaan wrote:

> But as I see, hda1 ends on block 2548269 and hda2 starts at 2538270.
> whatever you want to do, it will cause data loss. hda1 is as big as it
> be, so if you make it bigger you will erase a part of the linux
> (the most important part) and shrinking makes you loose data on the
> windoze partition.
> But can you mount the windoze partition under Linux? (mount -t vfat
> /dev/hda1 /mnt)? If so, the fats are ok too.

This is what tipped me off. It could indeed mount the partition, so I
tried booting into win98 again and it worked. LILO was still giving me
trouble when running it(NOT when booting) - something along the lines

Device 0x0300: Invalid partition table, 1st entry
  3D address:     32/1/0 (94)
  Linear address: 1/1/0 (63)

I have partition magic 6 installed and when I ran that - it told me that
there were some mismatches between the LBA and CHS values and offered to
fix them - I said yes.

Back in Linux now (and feeling much better) I checked with fdisk and
there doesn't seem to be a problem with that partition anymore and lilo
seems to run fine as well.

BTW, do you know of any software that would be able to do something
similar in Linux ?

Thanks for all your help, much appreciated.



Reply to: