[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]


hi ya cameron

yes... the docs are contradictory...

- wheny ou say you were buikdng a new raid under deb...
	- which kernel ???  and which raid tools...

mdadd is the old stuff
	- and requires raid0145 patches to 2.2.x and 2.0.x kernels

raidhotadd/raidstart is the current raid tools
	and does NOT require any patches for 2.4.x kernels
	unless you start to play with ata-133 stuff

mdadd/mdcreate uses /etc/mdtab ... and
its  /etc/raidtab under raidtools...

> I can do a mkraid -f /etc/raid/raid5.conf successfully, although when I go

if that works....

what is the output of `cat /proc/mdstat`

if you are doing raid5 ???  it gets messy to do root raid5....

if you are doing mirroring ...across 2 drives... those are lot easier...

please post your /etc/raid5.conf file for 2.4.x kernels
	- also verify that the kernel has raid support enabled
	into the kernel.. not as modules

	- cant read data off the raid disks till you have the ability
	to read the raid disks.... ( need initrd.gz files )

http://www.1U-Raid5.net .... 
( see the various interpretation of building software raid ... )

On Wed, 13 Feb 2002, Cameron Kerr wrote:

> Oh what a terrible week I'm having. I have a week left until classes
> start, and I've been trying to get a RAID5 array going under Debian for
> that whole friggin week! As you could probably appreciate, I'm a bit
> stressed about the whole thing.
> Basically, the docs seem to contradict one another, and nothing works as
> expected.
> I tried using RAID5, using a known-good kernel (from the old server,
> 2.2.19), on Debain Potato. The raid personalities are registered ok, but
> thats about all.
> mdadd complains about the individual partitions, saying that the device
> does not exist (_not_ `no such file or directory', that's simple to fix).
> I can do a mkraid -f /etc/raid/raid5.conf successfully, although when I go
> to put these entries in /etc/mdtab, the man page says its doesn't support
> raid 5!!!. Ok, so I'm not officially confused, and swearing (I've been at
> this for quite some time now). I've also tried it using a monolithic
> 2.4.17 kernel, with no difference.
> OK, so raid 5 doesn't want to work, when I reboot Debian (2.2r5 BTW), it
> can't mdadd the partitions, so it ckraid's them, every bloody time!
> I've partitioned the disks (there are three of them, each disk being a
> part of two raid volumes), and set them to raid autodetect (0xfd). It
> detects them at boot, but because they haven't been initialised, it won't
> add them (mdadd still won't work!)
> OK, so I decide that performance isn't really _that_ important, but I do
> need the reliability, so I decide to go raid 1 (I also tried raid 0, with
> no success) mkraid works ok, but mdadd _still_ doesn't work!
> If I can't get it working in the next two days, I'm gonna freak out!
> Does some kind soul have a reliable recipe for creating a raid array under
> Debian 2.2r5?
> I've read the docs in /usr/share/doc/raidtools/ too, btw....and the raid
> modules are loaded (raid[015])
> Thanks ever so much.... <sigh> I need a gin.
> Cameron Kerr
> -- 
> cameron.kerr@paradise.net.nz
> http://homepages.paradise.net.nz/~cameronk/
> -- 
> To UNSUBSCRIBE, email to debian-user-request@lists.debian.org 
> with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

Reply to: