[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

a problem with pcmcia-modules-2.4.17 in sid

I grew a little tired of compiling kernels with pcmcia support, and then not
being able to use my pcmcia hardware, so I decided to take a break from it
for a while and try a pre-compiled kernel
(kernel-image-2.4.17-386_2.4.17-1_i386.deb). I noticed in the description
for pcmcia-cs that:

	The actual kernel modules required for this package are contained in the
pcmcia-modules-package, where is the version of the kernel for which the
modules have been compiled.

So I downloaded the appropriate version of pcmcia-modules, and attempted to
install it. But it didn't work:

	icosagon:~# dpkg -i /floppy/*.deb
	Selecting previously deselected package psmcia-modules-2.4.17-386.
	(Reading database ... 20503 files and directories currently installed.)
	Unpacking pcmcia-modules-2.4.17-386 (from .../pcmcia-modules-2.4.17-386_
3.1.31-3k1_i386.deb) ...
	dpkg: error processing /floppy/pcmcia-modules-2.4.17-386_3.1.31-3k1
_i386.deb (--install):
	 trying to overwrite `/lib/modules/2.4.17-386/pcmcia/pcmcia_core.o', which
is also in package kernel-image-2.4.17-386
	Errors were encountered while processing:
	icosagon:~# dpkg-deb: subprocess paste killed by signal (Broken pipe)

After that happened, I took a closer look at the description for

	This package contains the set of loadable kernel modules for the PCMCIA
Card Services applications program interface. They have been compiled to 	be
compatible with the kernel in the kernel-image-2.4.17-386 package 	version

My system is mostly a combination of testing and sid, with a few
non-essential potato packages not yet upgraded. What should I do about this?
Should I just force it? All of these packages are the version that is in

Thanks for any help,


Reply to: