[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Joystick attached to USB port doesn't work

On Friday 14 December 2001 09:16 am, lorenzo.zampese@electrolux.it 
> My joystick/gamepad attached to the USB port doesn't work on my
> Debian (i386).
> I made my own kernel with USB support (usbcore.o, usb-hdci.o, hid.o,
> input.o,  joydev.o, etc.) and I tested it using:
> jstest /dev/input/js1
> jstest /dev/input/js2
> jstest /dev/input/js3
> and every time it reported me a message like this "device not found"
> , but devices are present in :
Your problem isn't exactly like mine -- I didn't have jstest installed 
and so don't know what would have happened with that.  But anyway, 
everything seemed to be installed and recognized with my USB joystick 
but no applications would work with it.  So here's what worked for me.  
Most applications look for the joystick at: /dev/js0 not 
/dev/input/js0.  So I added a symlink (ln -s /dev/input/js0 /dev/js0), 
rebooted, and everything worked.

David Bellows

Reply to: