[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

issues uninstalling courier-imap from woody


I upgraded from 2.2r2 cd install, to the woody via apt-get dist-upgrade some
weeks back.

Just lastnight I realised my imap server is not working, and when I
investigated why, it turns out /etc/courier is gone. Including config files.

So I figured I would uninstall and reinstall. But I am currently having
issues doing so.

Error is below;

utopia:/etc# dpkg --purge courier-imap
(Reading database ... 12530 files and directories currently installed.)
Removing courier-imap ...
ERR: config file missing
dpkg: error processing courier-imap (--purge):
 subprocess pre-removal script returned error exit status 1
ERR: config file missing
dpkg: error while cleaning up:
 subprocess post-installation script returned error exit status 1
Errors were encountered while processing:

I've also tried apt-get remove courier-imap and this also fails.

Anyone know how to force remove it? I tried using the stuff found in the
dpkg man packages but couldn't get it to work still.


Reply to: