[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Running remote X apps

Check your /etc/X11/xinit/xserverrc file.
If it has a line that contains "-nolisten tcp", remove that chunk.

On Fri, Aug 24, 2001 at 11:14:44AM -0700, Duncan Watson scribbled...
> I am having problems running apps on other machines that need to use my 
> display.   I suspect that X is not configured to listen to the right kind 
> of sockets or something. 
> Here is the scenerio, my machine name is pandora, ip  I telnet 
> into bravado (another linux machine) and check my DISPLAY.  I set it via: 
> 	setenv DISPLAY 
> I then run "xterm &" on bravado.  I get an error message 
> "/usr/X11R6/bin/xterm Xt error: Can't open display:"  
> I have tried "xhost +bravado", no luck.  I also tried "xhost +" as well on 
> my local machine.  No luck.  I used xauth as well.   
> on pandora:	xauth extract file $DISPLAY 
> on bravado:	xauth merge file 
> I am obviously missing something basic.  Can you help me? 
> TIA, 
> /Duncan 
> Oh BTW: the solution needs to work for generic unix boxen.  I am working 
> with a number of solaris and sco boxen that I don't have admin control on. 
> The linux box above is for testing.  My local box is of course Debian 
> linux. 
> --  
> Duncan Watson                                         deamonrift@yahoo.com 
>            ~~~      climbing in the Pacific NW       ~~~ 
> --  
> To UNSUBSCRIBE, email to debian-user-request@lists.debian.org  
> with a subject of "unsubscribe". Trouble? Contact 
> listmaster@lists.debian.org 

Reply to: