[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: X Display errors

Jason Majors <jason@whizzird.net> writes:
JM> Whenever I try to run something from an Eterm or xterm I get this error:
JM> xmms:  can't open display (null)
JM> But my display is set to "sabertooth:0.0". (The correct name).
JM> I've changed it to "localhost:0.0", "", and "". None
JM> of them work. I tried running "xhost +".

(Eep!  No!  *Never* run 'xhost +'; it lets anybody anywhere on The
Network (TM) connect to your X display, start programs, lock your
display, spy on what you're typing into your xterms, ...)

How are you checking what the current display is?  Does it work for
more benign X clients like, say, xclock?  For that matter, are you
actually using a remote X setup?  It looks like you aren't (since
'localhost' is one of the hostnames you tried); try setting DISPLAY to 
':0.0' (with no leading hostname) and seeing if that works.

JM> Below are my versions of everything that I think matters:
JM> ii  xserver-xfree8 4.0.3-4        the XFree86 X server

The Debian packaging of XFree86 4.x by default disables connections
via TCP, which means that xhost will never have any effect, and you'll 
never be able to connect to the machine by using 'hostname:0.0' as the 
display name.  This is probably a good idea in general, since there's
almost no security inherent to the X protocol.  If you need to run
programs on one machine and have them display on another, use ssh X
forwarding instead.

David Maze         dmaze@debian.org      http://people.debian.org/~dmaze/
"Theoretical politics is interesting.  Politicking should be illegal."
	-- Abra Mitchell

Reply to: