[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: timer command?

	Subject: Re: timer command?
	Date: Sat, Aug 04, 2001 at 07:51:53PM +0200

In reply to:Guy Geens

Quoting Guy Geens(ggeens@iname.com):
> >>>>> "Wayne" == Wayne Topa <wtopa@dmcom.net> writes:
> Wayne> On Potato it does. On Woody 'atd' isn't starting, no
> Wayne> var/run/atd.pid file. So forget 'at' on Woody presently.
> There must be something wrong with your installation: it works fine on
> my system.
> The .deb is still the same as in potato, and I wouldn't expect any
> problems with it.

Neither would I, but it isn't working.

I just purged at and reinstalled it from the net.
Setting up at (3.1.8-10) ...
Starting deferred execution scheduler: atd.

#ls /var/run/atd
ls: /var/run/atd: No such file or directory

#at 10:15 AM
warning: commands will be executed using /bin/sh
at> /root/bin/dodb
at> <EOT>
job 1 at 2001-08-05 10:15
Can't open /var/run/atd.pid to signal atd. No atd running?

# ps aux |grep atd
root       256  0.0  0.0  1408    4 ?        S    Aug03   0:00 /sbin/rpc.statd
root     24225  0.0  0.4  1304  512 tty2     S    10:10   0:00 grep atd

an strace of '/etc/init.d/atd restart' show a few interesting items.

open("/etc/init.d/atd", O_RDONLY|0x8000) = 3
ioctl(3, TCGETS, 0xbffff878)            = -1 ENOTTY (Inappropriate ioctl for device)
_llseek(3, 0, [0], SEEK_CUR)            = 0 read(3, "#! /bin/sh\n#\n# This file was aut"..., 80) = 80
_llseek(3, 0, [0], SEEK_SET)            = 0
shmat(255, 0, 0x2ptrace: umoven: Input/output error)                      = ?
shmat(255, 0x40014d34, 0x3ptrace: umoven: Input/output error)             = ?
fstat64(0xff, 0xbffff94c)               = 0
_llseek(255, 0, [0], SEEK_CUR)          = 0
brk(0x80ba000)                          = 0x80ba000

write(1, "Starting deferred execution sche"..., 42Starting deferred execution scheduler: atd) = 42
stat64(0x809a731, 0xbffff54c)           = 0
stat64(0x80b8a0c, 0xbffff45c)           = -1 ENOENT (No such file or directory)
stat64(0x80b8a0c, 0xbffff45c)           = -1 ENOENT (No such file or directory)
stat64(0x80b8a0c, 0xbffff45c)           = 0
stat64(0x80b8a0c, 0xbffff48c)           = 0

So I agree with you that it must be something wrong with my
installation.  This box went from slink to potato to woody and
'something' went missing. NOTE: 'at' was not installed on this
box before the upgrade to woody. 

I just checked another box that has a fresh install of potato.
'atd' is running on it and 'at' does work.  

So it looks like something went wrong with this box somewhere along the
update path.  Now I have to decide if I should do complete wipe of
the system and reinstall or try to figure out what went missing and
try to fix it. Humm, this is also the box that I had problems with
splitvt on.  The latest packages didn't work and Joey Hess said that
they should have worked.  Looks like a complete wipe is in order.

Thanks for the 'kick' to make me check this out.  I appreciate it.
Hope that this long missive will help someone else with a similar

Operator! Trace this call and tell me where I am.

Reply to: