[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: potato to sid upgrade error 32 broken pipe

> -----------
> 90 packages upgraded, 17 newly installed, 0 toremove and 3 not upgraded.
> 3 packages not fully installed or removed.
> Need to get 0B/19.5MB of archives. After unpacking 13.0MB will be used.
> Do you want to continue? [Y/n]
> perl: error while loading shared libraries: libdb.so.3: cannot open
> shared object file: No such file or directory
> E: Write error - write (32 Broken pipe)
> E: Failure running sript /usr/sbin/dpkg-preconfigure --apt
> sid:~#
It is not finding some perl modules that it needs.  The required packages are 
probably in your cache.  I suggest trying to manually install perl packages till
you get one to configure (dpkg -i someperlpack.deb).  Then get the others.  Once
you have a complete perl installation, try apt again.


Reply to: