[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

PCI weirdness

Still trying to track down a small problem with my Matrox G400 video
card (which I asked about last week), which I'm suspecting might be
related to these kernel warnings:

Jul 31 09:14:58 kernel: PCI: Cannot allocate resource region 0 of device 01:00.0
Jul 31 09:14:58 kernel: PCI: Failed to allocate resource 0(d8000000-d8ffffff) for 01:00.0

(device 1 is the video card), and this warning in XFree86.0.log:

(WW) MGA(0): Video BIOS info block not detected!

lspci reports:

01:00.0 VGA compatible controller: Matrox Graphics, Inc. MGA G400 AGP (rev 04) (prog-if 00 [VGA])
        Subsystem: Matrox Graphics, Inc. Millennium G400 16Mb SGRAM
        Flags: bus master, medium devsel, latency 32, IRQ 15
        Memory at d8000000 (32-bit, prefetchable) [size=16M]
        Memory at d4000000 (32-bit, non-prefetchable) [size=16K]
        Memory at d5000000 (32-bit, non-prefetchable) [size=8M]
        Expansion ROM at <unassigned> [disabled] [size=64K]
        Capabilities: [dc] Power Management version 2
        Capabilities: [f0] AGP version 2.0

Kernel 2.4.6, with mtrr enabled. X 4.0.3. 16Mb VideoRam.
Cat /proc/mtrr reports:

reg00: base=0x00000000 (   0MB), size= 128MB: write-back, count=1
reg01: base=0xd6000000 (3424MB), size=  16MB: write-combining, count=2
reg05: base=0xd0000000 (3328MB), size=  64MB: write-combining, count=2

There was some discussion of seemingly related problems in the kernel
mailing list archive some months ago, but nothing that suggested a
course of action. Has anyone any advice? Or where can I learn more
about this stuff?

I'd really appreciate any guidance anyone had to offer,


--text follows this line--

Reply to: