[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

missing consoles

Hello all.  I recently ran into a strange (to me, at least) problem on my
debian computer at home.  All of the virtual consoles are here.  I can
still use ctrl-alt-[1-7], but there are no login prompts (although gpm
still works fine, and I can type), and now X is on console 2 rather than
console 7.  

If someone could point me to the right place to look for information on
fixing this, I'd appreciate it.  btw, I have no idea what I did to cause
this (or I might have been able to figure out how to fix it).  It's been
like this for a few weeks, but I've been busy and am just now getting
around to looking at it.

Oh yeah, and another problem I ran into is that kdm won't recognise any
passwords.  Fortunately I had kdm set up with an account for my
brother-in-law that didn't require his password, so I was able to get in
that way, su to root and set it up so I don't require a password either.

All the authentication works fine for su and what not, so I'm guessing this
is a PAM problem, probably with /etc/pam.d/kde, but I'm not sure how to fix
it.  I'm sure with time, I'll be able to fix it, I've just been busy.  I
only mention it because it occurred to me that the problem with the virtual
consoles could be a related PAM problem.  

Also, the virtual console problem is why I haven't tried hard to fix the
kdm problem, since right now kdm is my only way to log into the machine.  I
haven't tried sshing in from work... I live in california and don't like to
leave my computer on using up power.  :)

Thanks in advance!
David Roundy

Reply to: