[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

ssh in unstable broken?



After I performed an update and upgrade with dselect last (yesterday, no 
changes as of this writing) I have gotten an error on trying to run ssh:

niels:/# ssh
OpenSSL version mismatch. Built against 90600f, you have 90601f

My first reaction was to uninstall ssh and install it again, thinking some 
version information had gotten confused, but to no avail.  Guessing that the 
ssh .deb int eh current unstable must have itself been compiled with a very 
slightly obsolete openssl, I tried downloading the source (I used apt-get 
source after adding the unstable deb-src lines to sources.list) and the 
openssl sources as well.  I spent a long time being confused as to why it 
wouldn't compile till I realized I needed the ssl dev sources as well 
(yea...) but eventually got it to work.  I still couldn't get ssl itself to 
compile, which confuses and annoys me but dosen't matter since ssh itself 
compiled fine.
(any ideas? ./config returns

make[1]: Entering directory 
`/home/rothaar/archive_downloads/openssl-0.9.6a/doc'make[1]: *** No rule to 
make target `links'.  Stop.
make[1]: Leaving directory 
`/home/rothaar/archive_downloads/openssl-0.9.6a/doc'
make: *** [links] Error 1

before dying...)

Anyway, I'm getting off the subject.
My problem is that while ssh itself works fine, sshd refuses to let me 
connect from anywhere.  I think this is either something to do with 
hosts.allow/hosts.deny (tho I never touched them before I had this problem) 
or that I messed something up in my several bungled attempts to compile.  My 
system didn't like the default settings for ./configure, I had to change the 
location of the binaries with prefix= and before I realized how that worked I 
manually moved some executables around (all gone now).

At long last, I have two actual questions:
Is there any way to clean out openssh and openssl and start over recomiling 
properly to start with? In general, when I compile something from sources, 
how do I remove it without knowing exactly what files it installs where?
Is this in fact an actual problem with the ssh .deb in unstable? (curiousity 
mostly here)

Thanks, hope I didn't jump around too much,

-Dan Berdine



Reply to: