[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

woody-problems: perl, locale, ppp and X4

Hi all!
I have 4 problems after dist-upgrading to woody: (in order of
descending importance ;-) )

Problem 1:)

When I start some programs (e.g. emacs) from an xterm, I get the
following message:

Warning: locale not supported by C library, locale unchanged

I think this one is related whith the one I saw more than thousand
times during apt-get working:

perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
	LANGUAGE = (unset),
	LC_ALL = (unset),
	LANG = "de_DE.ISO-8859-1"
    are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").

What do these mean, and how can I fix it?

Problem 2:)

I cannot transfer any data over my modem. I can dial out to my ISP, 
but I cannot connect to any http- or ftp-server. I cannot ping any
server, in fact, I cannot do anything. (pinging and connecting to
my local network still works, even when the ppp-connection is active)
So I started to look for the reasons myself: I noticed that ifconfig
shows me a network interface called "sl0", which I did not have before
the upgrade, and which is not listed in /etc/network/interfaces. This
interface is silent when the ppp-connection is off, but when having
dialed to my ISP, the number of "TX packets" on the ifconfig-output
(I hope anyone understands my quite confusing way of
describing this problem...)
Where does this interface come from, why is it there, and what is it
And how can I get to my ppp connection?

Problem 3:)

Where are my virtual consoles gone?

After booting, gdm starts, and I can switch to the consoles with
After logging into X, I can still access the console. But after logging
out of X, and in again, all I see when pressing Ctrl+Alt+Fx is a smaller
sized image of my X desktop (i.e. the login screen). Even when shutting
down, I do not see any messages from the init scripts, but only the X
login screen. Why could that be?

Problem 4:)

How do I enable Glide for my Voodoo3 in XFree 4? I have
    Load       "glx"
    Load       "tdfx"
in my XF86Config, /dev/3dfx exists (and worked with 3.3.6), 3dfx.o is
installed in the kernel (worked, too), and the manpage for tdfx does
not help at all (in fact, it does exist but there is nothing in it).

Example: Quake3 tells me:
...loading libMesaVoodooGL.so: Initializing OpenGL display
...setting mode 6: 1024 768
Using XFree86-VidModeExtension Version 2.0
Xlib:  extension "XFree86-DGA" missing on display ":0.0".
Failed to detect XF86DGA Mouse
XFree86-VidModeExtension:  Ignored on non-fullscreen/Voodoo
Using 4/4/4 Color bits, 16 depth, 0 stencil display.
Xlib:  extension "XFree86-DGA" missing on display ":0.0".
Xlib:  extension "XFree86-DGA" missing on display ":0.0".
gd error (glide): Can't find or access Banshee/V3 board
Received signal 11, exiting...

Do I have to upgrade to kernel 2 4 to get my games working again?

Any Idea?


Did you know that if you play a Windows 2000 cd backwards, you 
will hear the voice of Satan?

That's nothing!  If you play it forward, it'll install Windows 2000.

Reply to: