[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: wrong libc6 - ouch! (fwd)

> Subject: Re: wrong libc6 - ouch! (fwd)
> Date: Mon, 2 Apr 2001 09:07:20 -0400
> From: Rob Mahurin <robm@mad.scientist.com>
> To: "A. L. Meyers" <a.l.meyers@consult-meyers.com>
> CC: debian-user@lists.debian.org
> On Sat, Mar 31, 2001 at 07:35:54PM +0200, A. L. Meyers wrote:
> > So now my libc6 is .17 (should be .13 according to dpkg error message)
> > and is trashed. When trying to correct using e. g. "apt-get -f install"
> > I only get: "ldconfig missing". The install scripts exit.
> Try manually getting the version you need from the ftp server (wget
> ftp://ftp.debian.org/path/to/libc6.deb) and installing it with
> dpkg --install file.deb.
> If that doesn't work, find (or make) the rescue floppy from the
> original install; there are utilities on there for restoring broken
> debian systems.
> Hope that helps.
> Rob

I got the exact same problem when upgrading mount for my 2.4 kernel. I
used unstable (ughhh) version linked to the new libc6 which replaced the
ldso package containing the ldconfig. As a result I couldn't install any
package anymore!
Fortunally I had my debian cd still mounted (luck!) and could install
ldso and the old libc6.
Hope that helps


Reply to: