[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: AWE 32 not recognized

Keith & Cecile Schooley wrote:
> After compiling a kernel (2.2.17) for the first time, the startup sequence
> initialized Soundblaster at io 220 and 330, irq 1 and 5 (which is what it
> runs at under Windows), but then said "AWE 32 not recognized."  I still
> don't have sound.  (Compiled SB and PNP into the kernel.)
> I'm trying to avoid using isapnp tools, because I understand that they have
> trouble with AWE 32 anyway, and on an earlier attempt, pnpdump didn't
> recognize my sound card at all.

last i heard isapnp is required for the awe portion of the sb awe32. and
i have been using them on my awe32 for about 4 years. here is my
(READPORT 0x0273)

(CONFIGURE CTL0043/9961 (LD 0
 (INT 0 (IRQ 5 (MODE +E)))
 (DMA 0 (CHANNEL 1))
 (DMA 1 (CHANNEL 5))
 (IO 0 (SIZE 16) (BASE 0x0220))
 (IO 1 (SIZE 2) (BASE 0x0330))
 (IO 2 (SIZE 4) (BASE 0x0388))

 (NAME "CTL0043/9961[0]{Audio               }")
 (ACT Y)
(CONFIGURE CTL0043/9961 (LD 2
 (IO 0 (SIZE 4) (BASE 0x0620))
  (IO 1 (BASE 0x0A20))
  (IO 2 (BASE 0x0E20))
 (NAME "CTL0043/9961[2]{WaveTable           }")
 (ACT Y)

(CONFIGURE CTL0043/9961 (LD 3
 (IO 0 (SIZE 8) (BASE 0x0200))
 (ACT Y)

i should note that the first time i ran isapnp on my card it no longer
works UNLESS i do isapnp. specifying the module options doesn't work for
me anymore without isapnp(it used to). i believe i originally used isapnp
because i wanted to try out the awe part of my SB. it worked good. i have
8MB of ram on my card and have a 8MB soundfont..loaded it..played some of
my high quality midis ..they rocked..course only a couple programs(well i
think 1 - tkmidi ??) could do it..others locked up my system. i don't know
if isapnp affects it under win32 as i havent used win32 in years.


ICQ: 75132336

Reply to: