[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: unstable breaks kernel compile

Robert L. Harris (Robert.L.Harris@rdlg.net) wrote:
> I just ran a distupgrade to debian unstable.  I tried to compile my
> 2.4.2 kernel and I get this:
> make[1]: Entering directory `/usr/src/linux-2.4.2/arch/i386/boot'
> ld -m elf_i386 -Ttext 0x0 -s -oformat binary bbootsect.o -o bbootsect
> ld: cannot open binary: No such file or directory
> make[1]: *** [bbootsect] Error 1
> make[1]: Leaving directory `/usr/src/linux-2.4.2/arch/i386/boot'
> make: *** [bzImage] Error 2
> I saw an error durring the upgrade though.  It said "-oformat" had been
> changed out with "--oformat".  When I manually ran the command:
> ld -m elf_i386 -Ttext 0x0 -s --oformat binary bbootsect.o -o arch/i386/boot/bootsect.o
> then it seems to compile just fine.
> Not a good thing... Thoughts?
> Robert
I changing every -oformat to --oformat in
/usr/src/linux-2.4.2/arch/i386/boot/Makefile fixed it for me

//Florian Bartels <f-bartels@web.de><f-bartels@uni.de>     \\
||                <Power-two@gmx.de><f-bartels@extended.de>||
...file not found. Should I fake it? (Y/N)

Reply to: