[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: stuck in apt loop with gnome-libs-data



On Tue, Feb 27, 2001 at 12:04:28PM -0800, Adam Shand wrote:
> since i upgraded libc6 and dpkg (from unstable) i've been having a lot of
> problems with dpkg seg faulting trying to install stuff.  currently i
> tried to upgrade gnumeric and it bombs out on gnome-libs-data like this:
> 
> (Reading database ... 44809 files and directories currently installed.)
> Preparing to replace gnome-libs-data 1.2.8-helix1 (using .../gnome-libs-data_1.2.12-1_all.deb) ...
> Unpacking replacement gnome-libs-data ...
> dpkg: error processing /var/cache/apt/archives/gnome-libs-data_1.2.12-1_all.deb (--unpack): trying to overwrite `/usr/share/idl/name-service.idl', which is also in package libgnorba27
> dpkg-deb: subprocess paste killed by signal (Broken pipe)
> Errors were encountered while processing:  /var/cache/apt/archives/gnome-libs-data_1.2.12-1_all.deb
> E: Sub-process /usr/bin/dpkg returned an error code (1)
> 
> the problem is that i can't upgrade anything else until this is fixed, and
> i get this over and over again when i run "apt-get -f install" or try to
> manually install the package with dpkg.
> 
> i've had problems like this before and normally moving the problem file to
> /tmp and re-installing works (eg. mv /usr/share/idl/name-service.idl /tmp)
> to get my by ... but this time it doesn't.
> 
> how do i get out of this?

Add the follwing to your /etc/apt/apt/conf:

  DPkg::Options {"--force-overwrite";};

HTH,

-- 
Nathan Norman - Staff Engineer | A good plan today is better
Micromuse Inc.                 | than a perfect plan tomorrow.
mailto:nnorman@micromuse.com   |   -- Patton

Attachment: pgpe1gh9qq7eM.pgp
Description: PGP signature


Reply to: