[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: X problems after upgrade

On Sun, 25 Feb 2001, Nathan wrote:

->I recently upgraded to 4.0.2 from 3.3.6 using dselect so all dependencies
->should be OK and now X won't start at all. I ran xf86config and created the
->new XF86Config-4 file in /etc/X11 and every time I try to run X, it gives me
->this error msg:
->X: cannot stat /etc/X11/X (No such file or directory), aborting.
->giving up.
->xinit:  Connection refused (errno 111):  unable to connect to X server
->xinit:  No such process (errno 3):  Server error.
->Anybody know what's wrong?

I got the same error on 3.3.6 when I installed xfce from unstable.  The
problem was the symb link of /etc/X11/X -> /usr/X11R6/bin/XF86_Mach64
was removed.  I replaced the symb link and all was/is OK.
Maybe the same sort of thing is needed for the 4.0.2 version.

Hope this helps...

Christopher W. Aiken
Scenery Hill, Pa, USA
chris at cwaiken dot com
Debian GNU/Linux 2.2_r2

Reply to: