[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

eth0: unknown interface: No such device

OK here's the deal
I'm trying  to make a  bare-bonez floppy distribution  with networking
capability.  I'm testing it on my  usual workstation.  This machine
uses the  3c59x driver for eth0.  Now, I've compiled  the 3c59x driver
into the kernel on the floppy distro, but when I run ifconfig I get:

eth0: unknown interface: No such device. 

I've tried adding


as   arguments  to   the  kernel,   but   no  go   (I've  also   tried

I've also tried compiling the driver as a module but no luck with this
either ("Device or resource busy"). 

Again, both  approaches work fine on  this same machine as  far as the
O/S on  my hard drive  is concerned. It's  only in the context  of the
boot  floppies  that  it  bombs.  The  distro  on  these  floppies  is
home-brewed  and very minimal:  basically /sbin/init,  /bin/sh, /proc,
and   not  much   else.   So  maybe   I'm   missing  some   user-space
binary/config-file which is failing silently. Any suggestions? 


Reply to: