[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

apt-get mystery

apt-get wants to remove a number of packages during an install, and I'm not
sure why.  Furthermore, I'm not sure how to find out, in, general.

I'd be grateful for any help figuring out what's going on.

In particular, when I ask what it will do in upgrading wine, it
reports that it wants to knock out a seemingly unrelated package
(gnu-smalltalk) and that it plans to remove xpm4g, on which a large
number of other packages depend.

My system part way between potato and woody--basically, enough woody
to run helix-gnome.  In particular, I have not attempted an XFree86
4.0 installation.  I've put woody in my sources list and done
appropriate apt-get updates (and dselect updates) before my experiments.

So here's what apt-get tells me:
wheat# apt-get -qus install wine  #s -> trial run only
Reading Package Lists...
Building Dependency Tree...
Starting 2
Package gnu-smalltalk has broken dep on xpm4g
  Considering xpm4g 1 as a solution to gnu-smalltalk 0
  Removing gnu-smalltalk rather than change xpm4g
The following extra packages will be installed:
  libc6 libc6-dev libc6-pic libforms0.89 libfreetype6 libwine libxaw-dev libxaw6 libxaw7 xbase-clients xfree86-common
  xlib6g xlib6g-dev xlibs xlibs-dev 
The following packages will be REMOVED:
  gnu-smalltalk xcontrib xmanpages xpm4g xsm 
The following NEW packages will be installed:
  libfreetype6 libxaw-dev libxaw6 libxaw7 xlibs xlibs-dev 
The following packages will be upgraded
  libc6 libc6-dev libc6-pic libforms0.89 libwine wine xbase-clients xfree86-common xlib6g xlib6g-dev 
10 packages upgraded, 6 newly installed, 5 to remove and 319 not upgraded.
Remv gnu-smalltalk
Remv xcontrib
Remv xmanpages
Inst libc6-dev []
Inst libc6-pic []
Inst libc6
Conf libc6
Inst xlib6g-dev []
Inst xlibs-dev []
Inst libxaw7 []
Inst xlib6g []
Inst libxaw6 []
Inst libxaw-dev []
Remv xsm []
Inst libfreetype6 []
Inst xbase-clients []
Inst xfree86-common []
Inst libforms0.89 []
Remv xpm4g [navigator-smotif-476 gnucash xboard wmavgload
gnome-control-center gimp1.1 xscreensaver afterstep transfig
libgtkxmhtml1 gnome-utils ddd gnotepad+ gnomehack xemacs21-mule lyx
tkstep8.0 wine xfig xpdf nethack gnome-help xgalaga gnome-iconedit
grace python-gnome ]
	# YIKES! doesn't this mean all the listed packages
	# depend on xpm4g and will stop working?
	# and if all these depend on xpm4g, why remove only
	# gnu-smalltalk?
Inst xlibs
Inst libwine
Inst wine
Conf libc6-dev
[and the rest of the configures]

My apt.conf includes
Debug {
	pkgProblemResolver "True";
DPkg::Options { "--debug=400"; };

This is the best I can see to get diagnostic output.  I've also tried
dselect to look at the dependency info.  It hasn't helped much, though
it seems to show I have 3 versions of xpm installed, at least some of
which are incompatible with the others (xpm4, xpm4g, xpm4.7).

Reply to: