[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

386-4 Meg install question

Before I begin, let me apologize if this is a double.  I didn't realize it, but I sent the first one
before I was a member, so I am not sure that it went through.
    I have an old copy of Debian 1.3.1 on CD, and can also download whatever I need.
We are trying to set up an old 4-MB, 386 system (described below) with Linux, to use it as a mini-email
server for a Windows 95/98 ethernet network.  We are in Lithuania, which means that there is a lot
of hardware that is unavailable, including (at the moment) old SIMMS, so we can't upgrade the memory.
386 by TCI;  4 MB memory.  4 GB IDE hard drive. 
VGA by OAK Technologies OTIVGA 5792108
Serial card is called "Super I/O Card", FCC ID ID2-W83757
NIC:  COMPEX ReadyLink2000A - PNP ethernet card, NE2000 compat.  IO address 200-2B0  Interrupt # unknown.
BIOS Ameri. Trends
Current OS, DOS with Windows for Workgroups (we wish to keep the DOS, and use LOADLIN)
No CD - ROM (we have one, but the CD-ROM is not recognized by the system).
Additional potential problems: 
(1) Sometimes when we leave the computer on and untouched for long periods
of time, it locks up with a PARITY CHECK message on the screen.  (2) Although the NIC
nominally seems to work, we've never gotten it successfully interfaced with the rest of the
network.  Since we have no network experts, this could be due to our stupidity.
From your Debian 2.2 documentation, it looks like 2.2 requires a minimum of 12 MB of Ram.
So that wouldn't be good for us.  Likewise, I tried looking at the "small" 2-MB version of Debian
that is supposed to be available, but the server seems down, so that isn't available at the moment.
From the WGS Debian 1.3.1 CD, we made the 5 BASE disks, the Rescue Disk, the Root disk and the
LMEMROOT disk.  We also tried installing through LILO.  From the documentation that we got with 1.2.1,
it said we *had* to do a floppy install, we could not do the loadlin install.  However, as noted later, we
did try both, with different results.
From the Floppy Install, we put the rescue disk in and booted up.  The system came up to the initial
options page (where you can put command line options, or look at the F1-F5 help pages).  After
hitting Enter, it said "Loading Root.Bin ... Loading Linux .... uncompressing Linux ... booting kernal ...  Ramdisk: Compressed image found at Block 0".  And that is where it would stop forever after.  Note that it would never give me a chance to put the LMEMROOT disk in, or acknowledge that it was low on memory. 
Since I had a copy of lmemroot.bin in the main directory of the hard disk, I tried telling the system "LINUX root=/dev/hda1/lmemroot.bin" at the startup, but there was no difference.
I also tried LOADLIN (sure, it said I couldn't do it, but if nothing else is working ,why not give it a try.)
I got farther with that.  I got to "RAMDISK:  MINIX - Filesystem found @ block 0.  Loading 1200 blocks into RAM DISK  ... \ "  and it would stop there. 
(By stop, I mean that it did nothing more for the next 20 minutes.  Not even spinning the little / \ - | characters.)
Does anyone have a suggestion on what I can do to get this system up and running?  I am hoping to get this successfully installed on the computer that hasn't run before, because that becomes an increase in our assets without additional risk.
    - Michael Rudmin
      8-4 Laisves Kvartalas
      5730 Silute, Lithuania/Lietuva

Reply to: