[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: mutt -- compressed mailboxes, exerimental breaks 'open-hook', etc.



on Sun, Dec 31, 2000 at 12:46:54PM -0800, kmself@ix.netcom.com (kmself@ix.netcom.com) wrote:
> on Sat, Dec 30, 2000 at 03:04:39AM -0800, kmself@ix.netcom.com (kmself@ix.netcom.com) wrote:
> > on Fri, Dec 29, 2000 at 02:56:46AM -0800, kmself@ix.netcom.com (kmself@ix.netcom.com) wrote:
> > > Package: mutt
> > > Version: 1.3.12-2
> > > Woody.
> > > 
> > > I'd recently added the following lines to my ~/.muttrc to allow use of
> > > (and access to) compressed mailboxes.  They're now coming up as "unknown
> > > commands" on mutt invocation on an update to the latest mutt in Woody.
> > > Anyone know the problem or got a fix?  Bug tracking lists nothing
> > > appropriate on the topic.
> > 
> > It appears that the gzip patch was lost in the shuffle.
> 
> Officially, even.  It's listed in the README, as Marco d'Itri (mutt
> maintainer) pointed out in response to the bug report.  I've requested
> it be added, as this breaks backward compatibility.
> 
> Meantime, I'm about to learn how to compile from sources and apply the
> patch myself.  Tips, anyone?

Ok, got it figured out.

If you don't already, add a 'source' package list line to your
/etc/apt/sources.list file:

    deb-src http://http.us.debian.org/debian stable main contrib non-free

As root, from a directory you don't mind building in:

    $ apt-get update
    $ apt-get source mutt

Get the appropriate comresseded mailbox patch, and follow directions for
applying patch, from:

    http://www.spinnaker.de/mutt/compressed/
   
You need to create a new rules file from the old one as follows.

    [root@navel:debian]$ diff rules.old rules 
    17c17,18
    <               --with-pgp --with-mixmaster --with-ncurses --with-sasl 
    ---
    >               --with-pgp --with-mixmaster --with-ncurses --with-sasl \
    >               --enable-compressed

Build and make package.  Following assumes you're in the mutt source directory:

    $ debian/rules build
    $ debian/rules binary

If everything looks OK, install:

    $ dpkg -i ../mutt<version>.deb

You might want to place this on hold so it's not overwritten on your next 
upgrade:

    $ echo "mutt hold" | dpkg --set-selections

Cheers.

-- 
Karsten M. Self <kmself@ix.netcom.com>    http://kmself.home.netcom.com/
 Evangelist, Zelerate, Inc.                      http://www.zelerate.org
  What part of "Gestalt" don't you understand?      There is no K5 cabal
   http://gestalt-system.sourceforge.net/        http://www.kuro5hin.org

Attachment: pgpCKFzuuY94w.pgp
Description: PGP signature


Reply to: