[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Unidentified subject!


I have IMP running successfully on my server at home, and I just set it up on 
the server I maintain at work, and (of course :) now I'm having trouble with 
the one that *really* counts! :)

I'm running a fully updated Debian 2.2 server.  Here are the relevant packages 
I have installed:

horde 2:1.2.3-0.potato.4
imp 2:2.2.3-0.potato.4
mysql-client 3.22.32-3
mysql-server 3.22.32-3
imap 4.7c-1
libssl09 0.9.4-5
openssl 0.9.4-5
sendmail 8.9.3-23

I edited defaults.php3.in so that the only fields IMP would show are username, 
password and the language menu.  After running update-imp, when I checked out 
defaults.php3, it lists @default->server as '', which is the IP 
address for the NIC connected to the LAN.  It should be 'mail.wassoc.com' 
(which points to the IP address of the NIC connected to our DSL circuit).  How 
do I get defaults.php3 to read this correctly?

The next issue, which is the real trouble and possibly related to the question 
above, is that when a user logs in, they don't get the drop down menu in the 
upper left corner to switch folders, and when they click on the Folders link on 
the left, IMP logs them out and sends them back to the login screen.  This 
happens if any of the links on the left are clicked.  Interestingly, here is 
the syslog entry while this happens:

Dec  8 12:44:14 server imapd[6716]: connect from
Dec  8 12:44:14 server imapd[6716]: port 143 service init from
Dec  8 12:44:14 server imapd[6716]: Authenticated user=mattyt host=[]
Dec  8 12:44:16 server imapd[6716]: Logout user=mattyt host=[]

It appears that I'm logged out before I can even begin.  Even if I change 
user_change_server to "true" and change the entry from to 
mail.wassoc.com, I still get the same result, even in syslog:

Dec  8 12:46:15 server imapd[6723]: connect from mail.wassoc.com
Dec  8 12:46:15 server imapd[6723]: port 143 service init from
Dec  8 12:46:15 server imapd[6723]: Authenticated user=mattyt 
host=mail.wassoc.com []
Dec  8 12:46:17 server imapd[6723]: Logout user=mattyt host=mail.wassoc.com 

Again, I appear to be logged out immediately after being logged in, and any 
links on the left that are clicked send me back to the log in screen.

HELP!! :)

Thanks in advance,

Matthew Thompson       http://mattyt.net
mattyt@oz.net          http://www.oz.net/~mattyt
"They that can give up essential liberty to obtain a little temporary safety 
deserve neither liberty nor safety." - Benjamin Franklin

Reply to: