[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Logitech MouseManPlus, gpm, and X



Hi gang,

I had to reboot my system to add some ram, so I decided to see how my
mouse would go in the PS/2 port. It's a logitech MouseManPlus - very
cool mouse with lots of buttons!

I'm using gpm as a repeater, and use /dev/gpmdata as my pointer in my X
config file. The interesting bits of my gpm.conf are as follows:

device=/dev/psaux
responsiveness=15
type=imps2
append="-l \"a-zA-Z0-9_.:~/\300-\326\330-\366\370-\377\""
repeat_type=raw

In the pointers section of my XF86Config I have the following:

Section "Pointer"
   Protocol        "MouseManPlusPS/2"
   Device          "/dev/gpmdata"
   BaudRate        1200
   Resolution      100
   Buttons         5
   ZAxisMapping    4 5
EndSection

Now, everything works fine, except for the mouse wheel. It doesn't do
anything anymore (it occasionally does unpredictable things like sending
the pointer flying accross the screen, but nothing very useful).
Previously, when using my mouse as a serial mouse (with an adapter), it
worked perfectly. However, previously I had "ms3" as both the type and
repleat_type in gpm.conf, and "IntelliMouse" as the protocal in the
XF86Config. My understanding is that ms3 wouldn't have worked for a ps/2
mouse, but I could just be halucinating that, and "Intellimouse"
wouldn't work with the above (current) settings.

I suspect that maybe imps2 is not the best type for gpm for this
particular mouse, but I'm not sure what else to try (none of the others
look particularly more appropriate). Any suggestions would be
appreciated.

On a related note, I've noticed that the resolution of my mouse has
increased since I have put it in the ps/2 port (I need to move the mouse
further to make the pointer move the same amount). Does anyone know of
any way to ajust this is X or gpm (responsiveness in gpm doesn't seem to
have any noticable effect).

cheers,

damon

-- 
Damon Muller              | Did a large procession wave their torches
Criminologist/Linux Geek  | As my head fell in the basket,
http://killfilter.com     | And was everybody dancing on the casket...
PGP (GnuPG): A136E829     |                      - TBMG, "Dead"

Attachment: pgpv1EQmM3iHd.pgp
Description: PGP signature


Reply to: