[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Prob. with memprof (was: Re: top tells me X is using 80 Mb!)



On Tue, Nov 28, 2000 at 01:02:22AM -0200, Jeronimo Pellegrini wrote:
> 
> Ok, so I tried to run memproof on gnapster, and nothing happened...
> 
> Also tried gcalc, gnome-terminal, gtkcookie, gtkfind, gtkgraph, and
> same thing: nothing happened (as if the program had been started, but
> quit immediately).
> 
> Sme for xosview, xfig...
> 
> But it did work with wterm.
> 
> So... IS there some other application I could use to find memory
> leaks, other than memprof?
> 
> Memprof sems to be totally undocumented, and I tried several of the
> command line options, none of which worked...
> 
> Thanks,
> J.

Well, there are other ways, but it often involves recompiling.  That'd
probably have to be done anyway in order to track where exactly a leak
was coming from.  Go ahead and post a bug.  The worst that could happen
is you'll annoy some developer.  Just be cordial about how you phrase
it, and describe exactly how you described the problem before.

-- 
Eric G. Miller <egm2@jps.net>



Reply to: