[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]


I have had this problem before as well. I do not know what causes it, although
it usually happens after some kind of hardware issue.

Reinstall LILO and it should work fine. I am not extremely familiar with this
process, but there are good man pages (man lilo and man lilo.conf). Here are
some ideas I have:

If it is possible, repeat the way it is installed during Debian setup (I am new
to Debian, but I think that just dpkg -i [lilo pakage here] will work). Do
configuration options for it and it should ask you the basic questions.

The first time I solved this problem by using the "upgrade" feature on a redhat
cd, and didn't upgrade anything, but it reinstalled lilo I guess.

If that won't work, try /sbin/lilo (what the manpages are about). Back up the
configuration file, and do -t and -v with lilo a few times to get a feel for
what is going on. This will keep the changes from being committed.

By the way, you will need to boot in order to do all of this, a boot floppy will
work nicely, or use another computer if you have to. No way around finding
something bootable (unfortunately).

I have not had this problem in a while. I assumed that the newer versions of
lilo are rid of this. What version are you running?

Sorry, but I couldn't do as much research on this one, since I am not
knowledgable enough to mess with my boot sector when it is working already. If
you ever find out the cause, I would really like to know. One time this happened
to someone who I had just convinced to set up a linux box (in place of windows)
and he hasn't trusted linux much since then I don't think :(

I hope this helps,
    Jeff Davis

Andrew McRobert wrote:

> hi all
> I tried adding a ULTRA SCSI hard disk to the server (on the separate ULTRA
> SCSI channel on the controller), and while the system correctly identifies
> all of the attached SCSI devices (including the two other HDDs), it gives
> me this message when I connect the ULTRA SCSI drive:
> can't locate boot device
> If I disconnect it, ie. take my system back to exactly the way it was
> before, LILO stops at "LI"???!?!?!?
> Does anybody have any idea why this is happening??
> thanks a lot
> Andrew
> --
> To UNSUBSCRIBE, email to debian-user-request@lists.debian.org
> with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

Reply to: