[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: NEWBIE: unable to read mail

> > > > I guess this is something elementairy, but after some installs and
> > > > different configurations of my mailerdaemon (Postfix), I discovered that I
> > > > am unable to read mail with pine (the Inbox keeps standing at 0 messages).
> > > > Even when I stop Postfix. I guess there has been some change to the path
> > > > where incoming mail is stored. Received mail does appear in /var/mail/.
> > > > 
> > > > Someone know how to fix this?
> Normaly your incoming Mails are queued in /var/spool/mail/<user> (or related).
> Try to open your User file with a normal editor like emacs.
I already manually made a directory /var/spool/mail and copied my mailfile
from /var/mail/sebas to /var/spool/mail
I can read it, and received messaged are appended to the end of the file.

> I don't know where pine searches for the mailboxfile so you can check this.
Usually in /var/mail I guess, that always worked.

> Also interesting is with wich tool you get your mail?
> I use fetchmail and I recomend to use it for everyone else. So try a
> fetchmail -v.
I have just installed fetchmail, but how can I set the mailserver address.
I have already tried:
fetchmail -v --smtphost localhost --smtpaddress localhost
but fetchmail keeps complaining.

> > I also found out that when I log into my pop3 port (qpopper) and try to
> > login, the daemon responds:
> > -ERR maillock: cannot lock '/var/mail/sebas': !
> > 
> > and closes the connection. The directory exists and I set all the
> > permission bits, but it does not work. 
> Could it be that there is a lockfile in the directory?
already searched for it, but I only see the mailfiles of the users. There
is also nothing to find in /var/lock.


Reply to: