[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Trouble installng Tomcat on (Debian) Linux

[This is an update and re-post; as I got no reply and am still stuck]

I installed tomcat on my Debian Linux system from http://master.debian.org/~sgybas/tomcat

Apache runs fine, but I have tomcat problems. Jserv worked fine also, but I un-installed it and installed tomcat.

1) How do I test it with their examples? There is a webapps/examples.war; how do I invoke it?
    I inferred: //localhost/examples/Hello, is this correct?

2)  I want to run with Apache, so I started tomcat manually, then "include"ed the apache-tomcat.conf file into /etc/apache/httpd.conf.

I get an error that:
        [Mon Nov  6 11:14:02 2000] [warn] Loaded DSO libexec/mod_jserv.so uses plain Apache 1.3 API, this module might crash under EAPI! (please recompile it with -DEAPI)
        [Mon Nov  6 11:14:02 2000] [warn] pid file /var/run/apache.pid overwritten -- Unclean shutdown of previous Apache run?
        [Mon Nov  6 11:14:03 2000] [notice] Apache/1.3.12 (Unix) Debian/GNU tomcat/1.0 configured -- resuming normal operations
        [Mon Nov  6 11:14:03 2000] [notice] suEXEC mechanism enabled (wrapper: /usr/lib/apache/suexec)

3) If I try to connect to a .jsp file, I get:

Internal Server Error

The server encountered an internal error or misconfiguration and was unable to complete your request.
Please contact the server administrator, webmaster@omega.cs.mum.edu and inform them of the time the error occurred, and anything you might have done that may have caused the error.
More information about this error may be available in the server error log.

   omega:/etc/apache/logs# cat /etc/apache/logs/mod_jserv.log
        [06/11/2000 11:21:05:257] (EMERGENCY) ajp12: can not connect to host
        [06/11/2000 11:21:05:257] (EMERGENCY) ajp12: connection fail
        [06/11/2000 11:21:05:258] (ERROR) an error returned handling request via protocol "ajpv12"

4) I tried to look at examples.war, "jar -vft examples.jar", but it fails (see below), yet the startup (more below) seems to have successfully loaded them?

omega:/usr/share/java/webapps# jar vft examples.war
java.io.IOException: CRC of 0 is not valid in a DATA header
        at java.lang.Throwable.fillInStackTrace(Throwable.java:native)
        at java.lang.Throwable.<init>(Throwable.java:38)
        at java.lang.Exception.<init>(Exception.java:24)
        at java.io.IOException.<init>(IOException.java:25)
        at java.util.zip.ZipInputStream.closeEntry(ZipInputStream.java:137)
        at kaffe.tools.jar.Jar.listFilesInJar(Jar.java:605)
        at kaffe.tools.jar.Jar.processJar(Jar.java:402)
        at kaffe.tools.jar.Jar.start(Jar.java:60)
        at kaffe.tools.jar.Jar.main(Jar.java:39)

5) One concern in that the startup file (init.d/tomcat) says:
   "# Look for the right JVM to use - Tomcat does not work with Kaffe!"

but the error below reports Kaffe, and indeed:

        omega:/etc/init.d# java !$
        java -version
        Kaffe Virtual Machine
        Copyright (c) 1996-2000
        Transvirtual Technologies, Inc.  All rights reserved
        Engine: Just-in-time v3   Version: 1.0.6   Java Version: 1.1

In any case I never get any errors in tomcat.log (which in fact does not exist!)

Thanks for any help.
Gregory (guthrie@mum.edu)

I am running Debian Linux 2.2
        http://master.debian.org/~sgybas/tomcat/ (tomcat Version: 3.1.99b6-1)
        ibm-jdk1.1  (1.18)      [ibm-jdk-l118-linux-x86.tgz]
        ibm-jre1.1  (1.18)       [ibm-jre-l118-linux-x86.tgz]

omega:/usr/share/tomcat/bin# ./tomcat.sh run
Guessing TOMCAT_HOME from tomcat.sh to ./..
Setting TOMCAT_HOME to ./..
Using classpath: .:./../lib/servlet.jar:./../lib/tomcat.jar:./../lib/xerces.jar
org.apache.xerces.validators.datatype.InvalidDatatypeFacetException: [exception was kaffe.util.SupportDisabled: GNU gmp was not found by Kaffe configure script]
        at java.lang.Throwable.fillInStackTrace(Throwable.java:native)
        at java.lang.Throwable.<init>(Throwable.java:38)
        at java.lang.Exception.<init>(Exception.java:24)
        at org.apache.xerces.validators.datatype.XMLException.<init>(XMLException.java:line unknown, pc 0x83edb81)
        at org.apache.xerces.validators.datatype.InvalidDatatypeFacetException.<init>(InvalidDatatypeFacetException.java:line unknown, pc 0x851108a)
        at org.apache.xerces.validators.datatype.DatatypeValidatorFactoryImpl.createDatatypeValidator(DatatypeValidatorFactoryImpl.java:line unknown, pc 0x83491f2)
        at org.apache.xerces.validators.datatype.DatatypeValidatorFactoryImpl.createDatatypeValidator(DatatypeValidatorFactoryImpl.java:line unknown, pc 0x839bdfe)
        at org.apache.xerces.validators.datatype.DatatypeValidatorFactoryImpl.initializeRegistry(DatatypeValidatorFactoryImpl.java:line unknown, pc 0x83a71a7)
        at org.apache.xerces.validators.datatype.DatatypeValidatorFactoryImpl.<init>(DatatypeValidatorFactoryImpl.java:line unknown, pc 0x8337fca)
        at org.apache.xerces.validators.datatype.DatatypeValidatorFactoryImpl.<clinit>(DatatypeValidatorFactoryImpl.java:line unknown, pc 0x838826e)
        at org.apache.xerces.framework.XMLParser.<init>(XMLParser.java:line unknown, pc 0x8339456)
        at org.apache.xerces.parsers.SAXParser.<init>(SAXParser.java:line unknown, pc 0x82ad68a)
        at org.apache.xerces.jaxp.SAXParserImpl.<init>(SAXParserImpl.java:line unknown, pc 0x82c50ba)
        at org.apache.xerces.jaxp.SAXParserFactoryImpl.newSAXParser(SAXParserFactoryImpl.java:line unknown, pc 0x82ad1ae)
        at org.apache.tomcat.util.xml.XmlMapper.readXml(XmlMapper.java:213)
        at org.apache.tomcat.startup.Tomcat.execute(Tomcat.java:189)
        at org.apache.tomcat.startup.Tomcat.main(Tomcat.java:237)

2000-10-30 08:07:50 - ContextManager: Adding context Ctx( /examples )
2000-10-30 08:07:51 - ContextManager: Adding context Ctx( /admin )
Starting tomcat. Check logs/tomcat.log for error messages
No apps in webapps/
2000-10-30 08:07:59 - PoolTcpConnector: Starting HttpConnectionHandler on 8081

Gregory Guthrie
guthrie@mum.edu         (641)472-1125    Fax: -1103
Gregory Guthrie
guthrie@mum.edu         (641)472-1125    Fax: -1103
Reply to: