Re: libc6 >=2.1.94
john gennard <email@example.com> writes:
> Trying to install libmng_0.9.2-3.deb (from the command line)
> to satisfy a dependency of libqt2.2_2.2.1-4.potato.2_i386.deb
> and progress on to KDE2, I get the following error:-
> libmng depends on libc6 (>=2.1.94)
> version of libc6 on system is 2.1.3-10
> I've checked the error message twice - it's definately 2.1.94.
> I can find no libc6 greater than 2.1.3-13. Can anyone explain what is
> happening? Thanks, John.
Debian, like everything, has versions. The current version is
"potato", the previous one was "slink", the next will be "woody". The
names "stable" and "unstable" are a symbolic links to "potato" and
"woody", respectively. When woody is released, the "stable" symlink
will point to it. The main benefit of the stable release is, er,
stability. If you want some new functionality that isn't in the stable
release, look in unstable.
Since it takes some time to package software into debian packages and
so on, the current stable release of your favourite software may
actually be in an unstable release of Debian.
It looks here like you downloaded a package from "unstable" and are
trying to make it work with a "stable" distribution. This is possible
but not without upgrading other things (in this case, libc6), and
possibly breaking stuff.
Hopefully you are using apt-get to download packages, it automates the
process of downloading .deb files manually and running dpkg or dselect