[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Help! I upgraded ssh, it doesn't work, I want to go back to an earlier version.

Foolish me: I'd been happily running ssh 1:2.2.0p1 on my Potato
system, and then I upgraded to ssh 1:2.2.0p1-1.1.  (I got both of
those versions from "unstable".)  Well, that newer version doesn't
work on potato, because it requires a newer libc.  I don't care to
upgrade libc, and ssh is now brokenly installed, and will not start.
What's the simplest way for me to get a working ssh 2.2.0 server

I would *think* the easiest way would be to scare up another copy of
the 1:2.2.0p1 package, but I don't know where to find it.

I tried building the 1:2.2.0p1-1.1 package from source, on the
assumption that the version that I built would not require a newer
libc, but "configure" complained that it "Could not find working
SSLeay / OpenSSL libraries, please install".  I couldn't figure out
how to get past that point (yes, I tried installed OpenSSL).

So: any suggestions for how I can get SSH working again?


PGP Fingerprint: 3E7B A3F3 96CA 8958 ACC5  C8BD 6337 0041 C01C 5276

Reply to: