[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Recent Woody update - alsa broke gnome?



On Sat, Oct 14, 2000 at 02:49:43PM +0100, Lee Elliott wrote:
> After updating to the latest woody, something, I think alsa, broke
> gnome.  Both of these groups of packages were updated.
> 
> The problem occurs when trying to log into a Sawfish-Gnome session from
> gdm - the login window disappears but no Gnome session starts.  Logging
> into a console and running top shows that the system is quiet - nothing
> looping or zombied.  If I select a Debian session (icewm) I can log in
> ok.  Tried a re-boot - no difference.
> 
> I tried downgrading some of the packages that had been upgraded and
> which might have been responsible but it made no difference.
> 
> I then cleared out my /lib/modules and re-compiled my kernel (2.2.17). 
> I compile everything I need; SMP, SCSI support, h/w sensors etc. into
> the kernel, so the only module that gets made is soundcore.o. 
> update-modules ok.  After re-booting again, I was able to start a Gnome
> session ok, but with no sound, of course.
> 
> I then recompiled the alsa-driver for the sound card support I wanted -
> sb8 - ./configure + make install, which went ok.  update-modules ok.
> 
> Re-booting again left me with the original problem - unable to start a
> gnome session.
> 
> I've repeated this process a couple of times with the same results.
> 
> I had a look on the bug tracking system under gnome and alsa but didn't
> find anything that seemed to apply.  Has anyone else experienced the
> same problem, or can anyone tell me what I'm missing, possibly something
> obvious, before I bug it?
> 
> TIA
> 
> LeeE
> 

I can't claim to know much about sound support in linux. But, I ran to a
problem recently that may be related?  I attempted to intall:
  alsa-base
apt tried to download "alsa-base_0.5.9c-8.deb" which isn't a file on the server.
There is a "alsa-base_0.5.9d-1.deb". This would be in woody.

Maybe my problem is related to yours?

Kevin



Reply to: