[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Unidentified subject!

I'm reposting my problem, since I couldn't solve it.
So, I'm not receiving (CONNECT) from my modem. When am I supposed to get
it? Just after my ISP gives me a response? Or just after it accepts my

Another thing that is happening: When I send the AT commands to my modem,
it doesn't give me the answer immediately. It waits a few seconds (about
30!), to send me back OK. So, when I type pon, it delays about 90 seconds
to dial. This does not happen under windows. The dial-up is made
immediately. Could this be a serial port uart issue? You now, I already
tried setserial (...) uart 16450.

Thanks again,

>It looks like either your modem is not sending a connect message (just
>a CR), or the chat script is timing out before it is sent.  Maybe fiddle
>with the "expect" after dialing (or change the timeout, assuming that
>can be done).

Yes. It can be done. I'll try it out, tonight. --> so I tried;

>What does "Ats109=2<cr>" do (aside from setting register s109 to 2 :)?
Does nothing. I just found this command somewhere in the net. The manual
does not even report it.

>Have you tried sending ATZ first, then all three of the AT command
>sequences the win prog sends before dialing?

I'll try that, too. Thanks! --> so I tried;

>Well, not a solution, but try to add "kdebug 1" to your ppp options
>file. I'm experiencing a similar situation, but had no time to
>continue work on it. In my case, it seems that my configuration is
>rejecting pap authentication, but I couldn't see why. Maybe such a log
>might help somebody else on this list to find the solution.

I tried that, to, in place of debug. The logs are the same.

I'm sorry the long mail, but I would have no way of describing my problem
without it.

I'm trying to connect to my ISP, using my Lucent Venus Voice Modem, since
august, 2000.
I made these things:
-  ISA PnP issues, with pnpdump --> isapnp.conf
- setserial /dev/ttyS1 - the port whas detected as 16550A.

Well, now I have access to the modem. So I used pppconfig to set the chat
But the connection with my ISP is not going on. The modem dials, makes the
modem noise, but I think there's no handshake with my ISP. I tried PAP,
CHAP (even  Chat, but my ISP is windows based).

So I tought: the modem is not yet configured. I'll try to do it with AT
commands. This is my modem log under windows:

09-11-2000 02:52:45.44 - Lucent Venus Voice Modem in use.
09-11-2000 02:52:45.45 - Modem type: Lucent Venus Voice Modem
09-11-2000 02:52:45.45 - Modem inf path: ASKVENUS.INF
09-11-2000 02:52:45.45 - Modem inf section: Modem_Venus_IN
09-11-2000 02:52:45.70 - 115200,N,8,1
09-11-2000 02:52:45.70 - 115200,N,8,1
09-11-2000 02:52:45.70 - Initializing modem.
09-11-2000 02:52:45.70 - Send: AT<cr>
09-11-2000 02:52:45.72 - Recv: AT<cr>
09-11-2000 02:52:45.72 - Recv: <cr><lf>OK<cr><lf>
09-11-2000 02:52:45.72 - Interpreted response: Ok
09-11-2000 02:52:45.72 - Send: AT &F E0 &C1 &D2 V1 S0=0\V1w0<cr>
09-11-2000 02:52:45.75 - Recv: AT &F E0 &C1 &D2 V1 S0=0\V1w0<cr>
09-11-2000 02:52:45.75 - Recv: <cr><lf>OK<cr><lf>
09-11-2000 02:52:45.75 - Interpreted response: Ok
09-11-2000 02:52:45.75 - Send: ATS7=60S30=0L0M1\N3%C1&K3B0B15N1X4<cr>
09-11-2000 02:52:45.76 - Recv: <cr><lf>OK<cr><lf>
09-11-2000 02:52:45.76 - Interpreted response: Ok
09-11-2000 02:52:45.76 - Send: Ats109=2<cr>
09-11-2000 02:52:45.76 - Recv: <cr><lf>OK<cr><lf>
09-11-2000 02:52:45.76 - Interpreted response: Ok
09-11-2000 02:52:45.76 - Dialing.
09-11-2000 02:52:45.76 - Send: ATDT;<cr>
09-11-2000 02:52:49.30 - Recv: <cr><lf>OK<cr><lf>
09-11-2000 02:52:49.30 - Interpreted response: Ok
09-11-2000 02:52:49.32 - Dialing.
09-11-2000 02:52:49.32 - Send: ATDT#######<cr>
09-11-2000 02:53:21.68 - Recv: <cr><lf>CONNECT 115200 V42bis<cr><lf>
09-11-2000 02:53:21.68 - Interpreted response: Connect
09-11-2000 02:53:21.68 - Connection established at 115200bps.
09-11-2000 02:53:21.68 - Error-control on.
09-11-2000 02:53:21.68 - Data compression on.

So I tried this, with my /etc/chatscripts/provider  :

# This chatfile was generated by pppconfig 2.0.5.
# Please do not delete any of the comments.  Pppconfig needs them.
# ispauth PAP
# abortstring
# modeminit
'' 'AT &F0 E0 &C1 &D2 V1 S0=0\V1W0'
# ispnumber
OK-AT-OK ATDT6129220
# ispconnect
# prelogin
# ispname
# isppassword
# postlogin
# end of pppconfig stuff

This is my pap-secrets file:

# /etc/ppp/pap-secrets
# This is a pap-secrets file to be used with the AUTO_PPP function of
# mgetty. mgetty-0.99 is preconfigured to startup pppd with the login
# which will cause pppd to consult /etc/passwd (and /etc/shadow in turn)
# after a user has passed this file. Don't be disturbed therfore by the
# that this file defines logins with any password for users. /etc/passwd
# (again, /etc/shadow, too) will catch passwd mismatches.
# This file should block ALL users that should not be able to do AUTO_PPP.
# AUTO_PPP bypasses the usual login program so its necessary to list all
# system userids with regular passwords here.
# ATTENTION: The definitions here can allow users to login without a
# password if you don't use the login option of pppd! The mgetty Debian
# package already provides this option; make sure you don't change that.
# INBOUND connections
# Every regular user can use PPP and has to use passwords from /etc/passwd
*    frijole   ""   *
# UserIDs that cannot use PPP at all. Check your /etc/passwd and add any
# other accounts that should not be able to use pppd!
guest     frijole   "*"  -
master    frijole   "*"  -
# root    frijole   "*"  -               --------------------------> I'm
using my machine as root - this line was enabled and disabled
support   frijole   "*"  -
stats     frijole   "*"  -
# OUTBOUND connections
# Here you should add your userid password to connect to your providers via
# PAP. The * means that the password is to be used for ANY host you connect
# to. Thus you do not have to worry about the foreign machine name. Just
# replace password with your password.
# If you have different providers with different passwords then you better
# remove the following line.
rffjr provider <password is placed here>

I think I'm doing the same steps I use under windows, but nothing works.
When I type plog, the only information I have is that the chat script

These are the last lines of my /var/log/syslog:
Oct  3 04:12:35 colorado pppd[664]: pppd 2.3.11 started by root, uid 0
Oct  3 04:12:36 colorado chat[665]: abort on (BUSY)
Oct  3 04:12:36 colorado chat[665]: abort on (NO CARRIER)
Oct  3 04:12:36 colorado chat[665]: abort on (VOICE)
Oct  3 04:12:36 colorado chat[665]: abort on (NO DIALTONE)
Oct  3 04:12:36 colorado chat[665]: abort on (NO DIAL TONE)
Oct  3 04:12:36 colorado chat[665]: abort on (NO ANSWER)
Oct  3 04:12:36 colorado chat[665]: send (AT &F0 E0 &C1 &D2 V1 S0=0\V1W0^M)
Oct  3 04:12:37 colorado chat[665]: expect (OK)
Oct  3 04:13:05 colorado chat[665]: ^M
Oct  3 04:13:05 colorado chat[665]: OK
Oct  3 04:13:05 colorado chat[665]:  -- got it
Oct  3 04:13:05 colorado chat[665]: send (ATDT6129220^M)
Oct  3 04:13:05 colorado chat[665]: expect (CONNECT)
Oct  3 04:13:05 colorado chat[665]: ^M
Oct  3 04:13:50 colorado pppd[664]: Connect script failed
Oct  3 04:13:50 colorado chat[665]: alarm
Oct  3 04:13:50 colorado chat[665]: Failed
Oct  3 04:13:51 colorado pppd[664]: Exit.

The only information I have, now, is an alarm.
You may ask of the sequence ATS7=60S30=0L0M1\N3%C1&K3B0B15N1X4. I tried it
to, but nothing works.

I also tried to use C-Kermit. I can send AT commands, the modem responds to
them, but when I tried the dial command, it says that maybe there's a
trouble with the modem error-correction, that the modem may be RPI. My
modem is not RPI, it's an ISA pnp, but I tried to disable error-correction
with the &Q6 AT command (I have the modem AT commands manual)... same thing
as always.

1) Is there another way to watch the logs of my connection more closely?
2) Can the problem be with the serial port uart? I tried to setserial
16650, 16450, 16650, etc, but only 16650A works.
3) I tried another ISP (in Brazil, we have a few ISP's that are for free),
but ... nothing.
4) I tried to use CHAP, also. But nothing... I even checked the md5 and MS
80 definitions of CHAP, but they're right, according to the CHAP docs.
5) I'm almost trying Red Hat. Definitively, I'm not a linux guru (...yet).

Thanks for any help,


Reply to: