[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Help with Installation...

Sounds like the installation went better than you would think.  After
all, you apparently have a running system that you can log into.  So now
it's a matter of fixing those broken packages and configuring X.  When
the installation asked you about your mouse, that might have only been
for notifying the kernel or gpm (console mouse handling).  If you don't
have a file /etc/X11/XF86Config you certainly didn't configure X.

You don't mention if you installed off of CD or over a network with
floppies, or whatever.  If you installed off of CD, you might've had to
change CD at some point to install those missing dependencies.

dpkg and apt are generally pretty robust.  Generally a failure to
install a package will not be critical to the system, though some
programs may fail to work.  I'd suggest running dselect again to try and
fix your packages.  For X, you'll need to install the proper X packages
and possibly xf86setup if you want to use the GUI XF86Setup program.

So, good news is you have a working system.  Bad news is you still have
a little work to do to get everything installed/configured to your

BTW, /dev/mouse would just be a symbolic link to /dev/psaux in your
case.  Go ahead and make it if you like 'ln -s /dev/psaux /dev/mouse'.

On Sat, Sep 02, 2000 at 03:13:05PM -0700, Gutierrez Family wrote:
> Hello to all,  I apologize in advance for the length of this
> message...
> Today I began the installation of Debian 2.2.  It started out well,
> the config menus were very user friendly, etc.  It didn't end well,
> however...  Problems began after selecting the packages to install:
> I chose the "Simple" option to install packages.  I picked many, but
> not all.  The first sign of problems was during the "Setting up..."
> phase.  For one of the packages, I got a message like "dpkg:
> dependency problems prevent configuration of .....".  I just made a
> note of it.  This message came up several times, by the way.
> The second error message that I encountered said: "E: Sub-process
> /usr/bin/dpkg returned an error code (1) Some errors occurred while
> unpacking.  I'm going to configure the packgages that were installed.
> This may result in duplicater errors or errors caused by missing
> dependencies.  This is OK, only the errors above this message are
> important.  Please fix them and run [I]nstall again.  Press enter to
> continue"
> This didn't mean anything to me, except that it was bad and that I
> didn't have a clue how to fix anything either.  After this second
> message, the "Setting up ..." phase continued...  until I came to the
> third and final message:
> A blue screen titled "Debian Configuration" reported the following:
> "One or more packages failed to install.  This is probably due to bugs
> in the packages.  (Sorry; Debian's not perfect).  Simply trying to
> install those packages again may work around the problem, or at least
> move the installation process along a little further.  If you decide
> not to try again, bear in mind that some packages on your system will
> be in a broken state until you manually resolve the problem.  Packages
> failed to install.  Retry?"
> I chose YES, of course.  Installation continued for a few more
> seconds, then the "Debian GNU/Linux 2.2" login prompt came up (without
> rebooting the machine).  I logged in as root...  and once in, all I
> could do is stare at the prompt.  Apparently, the automated
> installation program had stopped.
> QUESTIONS: Is my system only partially installed?  Is it fully
> functional, or was there more do be done by the installation program?
> Out of curiosity, I tried "startx", but I got a "Fatal server error:
> cannot open mouse".  Funny, since I chose PS/2 mouse during the
> installation (and during Linux bootup, it "detected PS/2 port".  There
> is no "mouse" entry in /dev/ either.  I tried a simple command too,
> "more XF86Config", it said that the file did not exist, when in
> reality I was staring at it from the /etc directory.  I'm lost, please
> help !!!
> Any advice or suggestions would be greatly appreciated.
> Sincerely, Daly Gutierrez

/bin/sh ~/.signature:
Command not found

Reply to: