[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

All of a sudden can't load DBI.so


This is my first Debian posting so hope I'm not too off the mark in
describing my problem. Last Friday I couldn't get a web page to use "upload
file" properly. I thought maybe my cgi.pm was out of date so I decided to
use dselect to get newest version. Either I did something wrong or there
were some huge dependencies. It took about an hour to download and install
cgi.pm, I think a new version of perl and quite a few other files.

When I came back to work today I tried to run my web pages that use Mysql
and Perl DBI. Every time I tried I got this error in Apache error log:
"Can't load '/usr/local/lib/site_perl/i386-linux/auto/DBI/DBI.so' for module
DBI:/usr/local/lib/site_perl/i386-linux/auto/DBI/DBI.so undefined symbol:
Perl_markstack_ptr at /usr/lib/perl5/5.005/i386-linux/Dynaloader.pm.

I imagine this is a fairly obvious error and I may even have read about it
somewhere. But I have no idea now as to how to solve it. Can anyone help?



Reply to: