[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]


[Disclaimer: don´t waste your time reading if you´re not really 
interested, the "problem" is gone for now, and I´m just trying to find 
out what could have caused it.]

malloc: block on free list clobbered
last command: (null)
Report this to bash-maintainers@prep.ai.mit.edu

here we go...

I´m unsure if the bash-maintainers would actually like to hear about
as I´m pretty sure bash isn´t at fault here, but, as I don´t know what´s
wrong, let me give you a bit of background, maybe someone can shed a
little light on this:

My debian-box at home (slink, apt-get upgrade´d to potato, eg kernel
2.0.38) worked as usual, but I couldn´t login any more; ssh 
connections bombed out with the above error, ftp, sendmail etc
were running as ususal.

Now I ftp´d my mbox, read my mail, then got home; X was still running,
with ~20 xterms open, some of them with active ssh´s to other machines.
As soon as I pressed a key within the local shells it would bomb out,
whereas the ssh´s worked as ever. setiathome was running happily, I 
could even use Netscrap and gnapster, just as usual. Only bash was 
gone (and without a working shell, cron and friends won´t work :-( ).

I resetted the box, fscked (and prepared tomsrtbt, JIC), and now 
everythings back to normal.

Anybody´s got some hint? I´m running
"GNU bash, version 2.03.0(1)-release" aka "bash 2.03-6", btw.

Q: Can I just go and install a user with the same UID/GID as root, but
 /bin/tcsh as login-shell, so I have a fallback, JIC?


Reply to: