[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: broken mouse in x session

What if you stop gpm, and try again. (Start a x session, go back to 
console and do /etc/init.dgpm stop as root, or stop gpm first and then
start an x session).

Ron Rademaker

On Mon, 17 Jul 2000, Aaron Maxwell wrote:

> Hi.  I'm experiencing technical difficulties, 
> if you can help I'll love you forever...
> I'm running what was CorelOS, pretty much converted to woody (remove
> all the packages with "corel" in them, edit sources.list, then apt-get
> update && apt-get upgrade).  My mouse doesn't work in X, much as if I had
> the wrong argument to Protocol in 'Section "Pointer"' of XF86Config.  
> Odd thing is, 24 hours ago it worked fine.  It stopped when I was apt-get
> install'ing things left and right [1], so I'm not sure what triggered it. 
> (it stopped working right after I installed ssh.  Hm.)  In XF86Config, the
> Protocol and Device for the pointer (mouse) were "PS/2"  and "/dev/mouse"
> (/dev/mouse isa symlink to /dev/psaux). In the console, gpm still works
> fine, and it has the equivalent settings in its config file
> (/etc/gpm.conf; device=/dev/psaux, type=ps2). 
> I have a very normal, 3-button, contemporary-model Logitech mouse, with a
> PS/2 connector.  In XF86Config, I tried changing the Protocol to (almost) 
> everything listed in man XF86Config; and changing the Device to /dev/psaux
> and /dev/ttyS[0123].  In short, I tried every suggestion I found in the
> archives in debian-user and my head.  No avail.
> I did find that changing Device to be "/dev/gpmdata" and Protocol to
> Microsoft, MouseMan, or MouseSystems, it worked fine except my mouse's
> middle button didn't work.  I use this button a lot.  I can
> Emulate3Buttons, but it's not the same. 
> btw, this seems independent of WM (tested with twm; and enlightenment,
> both with and without gpm).
> Thanks in advance.
> Aaron
> [1] CorelOS is OK, except for the packages it's missing on the distro CD.
> Didn't even have emacs, for chrissakes...
> -- 
> Unsubscribe?  mail -s unsubscribe debian-user-request@lists.debian.org < /dev/null

Reply to: