[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

[msoulier@storm.ca: logs]

	Well, I tried the ne2k driver for that soho card, and it wouldn't install,
saying "device or resource busy". So, I tried the tulip driver, which
installed. On a reboot, eth0 was detected (woohoo!). Then, I installed dhcpcd,
and gave it eth0 as the interface. It segfaulted. 

	Now, when I boot, the boot process stops at sendmail. I can boot into
single-user mode to play with it, but dhcpcd segfaults every time. I've
attached my boot log, and the message from dhcpcd when it dies. Suggestions
would be greatly appreciated. 

	Does this mean I don't have network support in my kernel??


Michael P. Soulier, 1Z22, SKY  Tel: 613-765-4699 (ESN: 39-54699)
Optical Networks, Nortel Networks, SDE Pegasus
"...the word HACK is used as a verb to indicate a massive amount
of nerd-like effort."  -Harley Hahn, A Student's Guide to UNIX
Nortel Linux User's Group Ottawa: (internal) http://nlug.ca.nortel.com:8080
--- Begin Message ---

Linux version 2.2.12 (root@crashtest) (gcc version #2 Thu Aug 26 11:46:26 PDT 1999
Detected 451033251 Hz processor.
Console: colour VGA+ 80x25
Calibrating delay loop... 450.56 BogoMIPS
Memory: 62876k/65536k available (1244k kernel code, 416k reserved, 900k data, 100k init)
CPU: Intel Pentium III (Katmai) stepping 03
Checking 386/387 coupling... OK, FPU using exception 16 error reporting.
Checking 'hlt' instruction... OK.
Checking for popad bug... OK.
POSIX conformance testing by UNIFIX
PCI: PCI BIOS revision 2.10 entry at 0xfb460
PCI: Using configuration type 1
PCI: Probing PCI hardware
Linux NET4.0 for Linux 2.2
Based upon Swansea University Computer Society NET3.039
NET4: Unix domain sockets 1.0 for Linux NET4.0.
NET4: Linux TCP/IP 1.0 for NET4.0
IP Protocols: ICMP, UDP, TCP
Starting kswapd v 1.5 
Detected PS/2 Mouse Port.
RAM disk driver initialized:  16 RAM disks of 4096K size
loop: registered device at major 7
PIIX4: IDE controller on PCI bus 00 dev 39
PIIX4: not 100% native mode: will probe irqs later
    ide0: BM-DMA at 0xf000-0xf007, BIOS settings: hda:DMA, hdb:DMA
    ide1: BM-DMA at 0xf008-0xf00f, BIOS settings: hdc:DMA, hdd:DMA
ide0 at 0x1f0-0x1f7,0x3f6 on irq 14
ide1 at 0x170-0x177,0x376 on irq 15
hda: QUANTUM FIREBALLP KA13.6, 13216MB w/371kB Cache, CHS=1684/255/63
hdd: ATAPI 40X CD-ROM drive, 128kB Cache
Uniform CDROM driver Revision: 2.55
Floppy drive(s): fd0 is 1.44M
FDC 0 is a post-1991 82077
md driver 0.36.6 MAX_MD_DEV=4, MAX_REAL=8
NCR53c406a: no available ports found
Failed initialization of WD-7000 SCSI card!
megaraid: v1.04 (August 16, 1999)
scsi : 0 hosts.
scsi : detected total.
Partition check:
 hda: hda1 hda2 < hda5 hda6 hda7 hda8 >
VFS: Mounted root (ext2 filesystem) readonly.
Freeing unused kernel memory: 100k freed
Adding Swap: 200772k swap-space (priority -1)
parport0: PC-style at 0x378 [SPP,PS2]
lp0: using parport0 (polling).
Serial driver version 4.27 with no serial options enabled
ttyS00 at 0x03f8 (irq = 4) is a 16550A
ttyS01 at 0x02f8 (irq = 3) is a 16550A
CSLIP: code copyright 1989 Regents of the University of California
PPP: version 2.3.7 (demand dialling)
PPP line discipline registered.
PPP BSD Compression module registered
tulip.c:v0.89H 5/23/98 becker@cesdis.gsfc.nasa.gov
eth0: Macronix 98715 PMAC at 0xe400, 00 80 c6 f1 68 fa, IRQ 10.
eth0:  EEPROM default media type 10baseT.
Unable to handle kernel NULL point dereference at virtual address 00000000 current->tss.cr3 = 03d63000, %cr3 = 03d63000

--- End Message ---

Reply to: