[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Update this morning killed local login. (I think I found it)

At 09:53 AM 3/2/00 -0500, Ben Collins wrote:
On Thu, Mar 02, 2000 at 09:46:37AM -0500, Todd Suess wrote:
> Greets ppl,
> I did an apt-get dist-upgrade this morning, and after that I can no longer
> log in to the console.  I had just rebooted after the update, and was watching
> the kernel boot messages, when I saw something strange pop up.  It was similar
> to the following (going from memory)
> Checking for valid XFree86 configuration file.....unable to check!
> Not starting KDM Windows Manager
> I then got a normal non X login console screen, but no matter what
> username and password I use, I get invalid login.
> Luckily my machine is on a cable network and I was able to ssh in
> from work, so the machine is accepting remote passwords, just not
> console logins.  Since I am sshing in I have not tried starting X remotely
> yet, wanted to see if anyone had any ideas before I muck around too much.
> One thing I did notice was that the Login package was updated in the update
> this morning, and it was right after that that things stopped working.

Can you be more specific as to the problem, as in what messages come up
when you type in your username and password?

Also try typing in your password on the username line to make sure it is
coming up as it should. It is a known issues that kbd is for some reason
setting up systems as azerty keyboard instead of qwerty, like it should.


Just for the heck of it, I decided to see what was happening at the end of the kernel boot
sequence when it went to check for a valid Xwindows config.  I checked the following and
this is what I found.

blackhole:/etc/alternatives# update-alternatives --display x-window-manager
x-window-manager - status is manual.
 link currently points to /usr/bin/X11/vtwm
/usr/bin/kde - priority 10
Current `best' version is /usr/bin/kde.

I have not had vtwm installed for a long time, for no apparent reason my x-window-manager
was updated to a nonexistant window manager, thus the problem.  Not sure if this would affect
local console login, but could it?  I tried to do this:

blackhole:/etc/alternatives# update-alternatives --config x-window-manager

There is only 1 program which provides x-window-manager
(/usr/bin/kde). Nothing to configure.

What would be the correct procedure to get things back pointing at kde again?



Version: 3.12
GAT d- s:++ a C++++ UL++++ P+ L++ E---- W++ N++ o-- K- w
O- M-- V-- PS+ PE Y++ PGP 5++ X++ R* tv+ b+ DI++ D++
G e h--- r+++ y+++

Reply to: