[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Upgrading kernel from 2.0.38 to 2.2.14 ?


I have a debian linux box running 2.0.38

Ive just updated all the packages from hamm to slink but I also
want to now upgrade to kernel to 2.2.14 ? .. 

What I am wondering is what problems if any am I faced with .. 

I am running IP Masquerading .. linux box connected to net, local
network of 10.x.x.x and then a win95 box behind the linux box
on the local net.

I havent read much about ipchains .. but know how to use ipfwadm, is
there a backward compatability?

Ive been reading some docs .. and found that I also need to do the following :

make some minor modifications to the route commands in the
/etc/init.d/network script, ie:

route add -net


route add -net netmask

And also make sure that the following links are in place:

/usr/include/linux -> /usr/src/linux/include/linux
/usr/include/asm -> /usr/src/linux/include/asm-i386

Is there anything else or other suggestions anyone can give me ?

Thanks in advance.

Anthony Green

Reply to: