[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: xxx.tar.gz on Windows.

Darxus wrote:
> On Fri, 26 Nov 1999, Jens K. Olsen wrote:
> > I know this is a little off subject, but I think it's a problem may
> > people are running into.
> >
> > I have a ftp server with lot's of files on it. I usually use .tar.gz for
> > large archives rather than .zip because not all my UNIX users has unzip
> > installed. Winzip supposedly supports tar and gz also.

It does.

> > I recently found that when my Windows users download the .tar.gz
> > archives using Netscape and try to unzip them using Winzip, they get an
> > error message and they don't get anywhere.

What error message? Invalid file? Does it try to create a new file with
the .tar.gz file as the contents?

> > I would like to understand what is going on, and how I can fix the
> > problem. If anyone had the same problem and found a good solution
> > (meaning NOT having to use .zip rather than .tar.gz, and NOT having to
> > use that terrible "OS" called Windows), please let me know.

Netscape tries to be 'too smart' with tar.gz files. It un-gzips them for
you as it downloads, which basically corrupts anything that isnt text
(but the un-gziped file still has the .gz extension). The result is that
Winzip doesn't recognise it, neither would gzip, although you might be
able to un-tar it if you're lucky.

The usual solution (that I've seen posted many times on various linux
lists) is to hold down shift when clicking to force Netscape to download
it. Trouble is, I *do* do this, yet still manage to end up with a
corrupted file (although I admit that occasionally it does work - maybe
it has something to do with the server?). As an example, yesterday I
tried to download the source to glibc2.1.2 from ftp.gnu.org. I
shift-left-clicked as usual. The save dialog box said it was receiving
an (approx) 8Mb file. However, explorer shows the size as 43Mb, and
Winzip refuses to open it. When this happens, I usually turn to either
ncftp, if the file is on an ftp site, or Lynx. If I'm on a windows box,
I'll even load up IE to get the file (because IE does the right thing
with it - I hate it when that happens...).

(I've just received Eric Miller's reply, so I'll make some comments on
that as well)

Eric says:
> 1) tell your user's to Shift-Click the links to download, and/or make
> sure Netscape isn't decompressing the files when it downloads them
> (probable cause).

I do shift-click, but it doesn't always work.

I have tried to tell netscape to 'save to disk' with the following:
Compressed Data, Unix Tape Archive, Winzip File (TGZ)
... even added my own *.gz type with 'save to disk' as the action. It
*still* doesn't work.

Mozilla M11 (Win32) doesn't seem to do anything useful (just sits there
and does nothing).

> 2) check that the files aren't being renamed to xxx_tar.gz . For some
> reason this happens on some windows boxen. They have to be renamed to
> xxx.tar.gz to be useable.

Tried renaming the file before saving. The file name is correct, but it
is still corrupt.

> 3) possibly give your files the *.tgz extension. It should be recognized
> as a compressed tar archive by Winzip (tar czf xxx.tgz mydir).

Nope, still doesn't work.


Reply to: