[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

compiling LIcq plugins/compiler library problems



I'm having a problem compiling plugins for licq, but I think the problem
isn't that related to licq.  I get an error when trying to add the qt
library.  Here's the error:

c++ -fno-rtti -fno-exceptions -g -O2  -I/usr/lib/qt2/include
-I/usr/include/kde -o licq_qt-gui.so obj/icqfunctions.o obj/outputwin.o
obj/awaymsgdlg.o obj/adduserdlg.o obj/authuserdlg.o obj/userbox.o
obj/licqgui.o obj/mainwin.o obj/mledit.o obj/searchuserdlg.o
obj/messagebox.o obj/chatdlg.o obj/optionsdlg.o obj/ewidgets.o
obj/chatacceptdlg.o obj/fileacceptdlg.o obj/filedlg.o obj/showawaymsgdlg.o
obj/sigman.o obj/skin.o obj/utilitydlg.o obj/wharf.o obj/editgrp.o
obj/skinbrowser.o obj/registeruser.o -shared -nostdlib  -L/usr/X11R6/lib
-L/usr/lib -L/usr/lib -lSM -lICE -lqt -lX11 -lXext -lXss   
/usr/bin/ld: cannot find -lqt
collect2: ld returned 1 exit status
make[1]: *** [licq_qt-gui.so] Error 1

My question is, why can't the compiler find the qt library?  I've compiled
it before, but that is when I was running slink.  I am now running potato,
so I'm wondering if something has broken?  If not, anyone know how to fix
this problem?

								Rob

ratirh@lore.cs.purdue.edu   1999-00 |
Aka Khyron the Backstabber          |       L    I  NN N  U U  X X  O
ICQ# 2325055                        |       L    I  N NN  U U   X
                                    |       LLL  I  N  N  UUU  X X  O
"Shackles cannot keep me bound      |          Those who can, do.
 forever.  I'm outta here."         |


Reply to: