[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: dpkg-dev / dpkg broke? - POTATO

     This appeared to be an overwrite issue to me, so I downloaded
dpkg_1.4.1.8.deb via netscape (found it through "packages" on the
debian www site) and did
dpkg --force-overwrite -i dpkg_1.4.1.8.deb
to install it.  It worked, although there might be a better way
now (through apt, maybe?).  And BTW, dpkg-dev was installed via
dselect apt here _before_ I had the dpkg archive misnomer and 
overwrite problems.  ...hope this helps all those of you upgrading
potato.  :-)


On Tue, Sep 14, 1999 at 07:29:05PM -0400, David Z. Maze wrote:
> Seth R Arnold <sarnold@willamette.edu> writes:
> SRA> I get this error on my potato i386:
> SRA> dpkg: error processing /var/cache/apt/archives/dpkg_1.4.1.8_i386.deb
> SRA> (--unpack):
> SRA>  trying to overwrite `/usr/share/man/man1/dpkg-buildpackage.1.gz', which is
> SRA> also in package dpkg-dev
> Among the packages APT didn't install is the new dpkg-dev; if you run
> 'apt-get install dpkg-dev' and then proceed with the upgrade it works
> fine.
> dpkg should probably Conflicts: with dpkg-dev (<=
> -- 
> David Maze             dmaze@mit.edu          http://donut.mit.edu/dmaze/
> "Theoretical politics is interesting.  Politicking should be illegal."
> 	-- Abra Mitchell
> -- 
> Unsubscribe?  mail -s unsubscribe debian-user-request@lists.debian.org < /dev/null

Reply to: