[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Printing *should* work...

On Fri, 10 Sep 1999, Mark Mackenzie wrote:

> This may be a stab in the dark, but I once had a similar problem.
> After each bootup, I could not print untill I had done a
> dpkg -i lpr_whatever.deb

 Hmmm. I finally did get things working this morning; I reran
"magicfilterconfig --force", and so far as I can tell gave identical
responses, but now it works.

> For some reason, simply restarting the lpr daemon did not seem to get
> printing to work (yes, I know that sounds very hard to believe).

 Not to me; I just had something like that last night. I ran "lpc" and
told it to restart the daemon, but it couldn't. I did an "strace" and saw
it was looking for "/dev/printer". I created a symlink from "/dev/printer"
to "/dev/lp1" (yup, that was the right device), and then it failed trying
to open it as a socket.

 A little knowledge is a dangerous thing, I guess. I swear I hadn't done
anything else before the daemon stopped working, just a reboot.

> Maybe you could try the lprng package in extra (I am using that now
> actually).

 I may just. Anyway, things are working right now; now I'm gonna try to
set up remote printing from the network...


 Ray Ingles          (248) 377-7735          ray.ingles@fanucrobotics.com
 "Computers let you make more mistakes faster than any other invention
  in human history, with the possible exception of handguns and tequila."
                           Mitch Radcliffe

Reply to: