[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Obscure ethernet/IDE trouble

William T Wilson wrote:

> On Fri, 3 Sep 1999, Adam C Powell IV wrote:
> > > I get this all the time when I try to access a drive that is in sleep
> > > mode.  It takes it a minute or two and then it comes back to life and
> > > works normally.  I have an old '96 era Intel Triton motherboard.
> >
> > Okay, but why would my drives be sleeping?  This happens during the
> > first disk access after a net access, could the net driver be putting
> > the drives to sleep?  And why does resetting the IDE interfaces kill
> > my networking ability?
> They probably aren't, but based on what you have to say here, I'd check
> and make sure that your network card isn't sharing an interrupt with your
> ide interface.

Ahem, from the original post:

Adam C Powell IV wrote:

> Greetings,
> [snip]
> There shouldn't be an IRQ conflict, because the net cards are on IRQs 10
> and 5, and the ide0 and ide1 are at 14 and 15 respectively.  I tried
> network stop; ifconfig eth0 down; rmmod 3c59x; modprobe 3c59x; network
> start but the network is still dead.  It remains dead until I do a full
> halt and power down, after which it comes back- until the next disk
> access.

Other ideas?

That the IDE reset an network failure always happen at the exact same time
(and I've tried about 20 times now, so yes, it's repeatable) suggests the
two things might be linked...

I just got a new box with a CD-R, so I'm going to try to burn a Debian
image then install the CD on the dual-celeron and just install the system
from that.  This is getting old.  If it persists with the Slink install,
then I've got bigger problems. :-(

Thanks very much for your efforts!

-Adam P.

Reply to: