[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

lp not printing

Ever since I installed Debian slink, I have not been able to print.  I had been
using Magicfilter under the previous version with no problems.  Now, I can print, as root, if I send directly to /dev/lp1, but anything else fails.

I had uninstalled and reinstalled everything associated with the printer, so I assume the permissions on lpr and magicfilter were correct; at any rate, they show the same permissions I had before I installed slink.

So, I created my own filter, and tried printing using the filter.  I can still print if I use the commands in the filter and direct the output to /dev/lp1.  But if I try to print using lpr, the printer doesn't print, and I get a mail message from "daemon" with the subject line "lp printer job <title>" which states thatthe job in question did not print.  The lpr.log shows the same thing.

The filters I created are in /usr/local/bin which is owned by root:staff, they are set to mode 755, and they are owned by root:root (I also tried setting them to root:lp).  The printcap entry for the printer is (this is as created by Magicfilter, except that I changed the filter file used):

lp|hpdj722|HP Deskjet 722c:\

I am not able to print without a filter, as the printer is an HP 722c, and requires a special program (pbm2ppa) to create the output the printer understands.

Can anyone tell me what is going wrong here?

Steve Martin

Reply to: