[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

SV: A little further: Short newbie question

Thanks a tremendous lot for all the help. It really helps keeping my spirit
up as a newbie.
I managed to mount the dos partition allright, but it seems like dselect
wants an exact copy of the ftp-site, which is a problem since I can't make
the directory "binary-i386" with only 8 characters allowed in dos.
Seems like I'm gonna have to borrow a cd-drive off of somebody and try to do
the installation from there, alternatively (re)install the winbastard in the
dos-partition to be able to use longer names. Damn.
Anyone got any brilliant ideas for a (masochist?!) newbie?!

Error is human; complete disaster takes a computer... 

> -----Oprindelig meddelelse-----
> Fra:	Kent West [SMTP:westk@nicanor.acu.edu]
> Sendt:	8. juni 1999 19:15
> Til:	Wichmann, Viggo
> Cc:	debian-user@lists.debian.org
> Emne:	Re: A little further: Short newbie question
> vw@geus.DK wrote:
> > Ok, now I got a little further: I typed /dev/hda and dselect asks:
> > Enter filesystem type for dev/hda:
> > What's linuxian for a dos filesystem?
> > Vitux
> >
> > > -----Oprindelig meddelelse-----
> > > Fra:  Wichmann, Viggo
> > > Sendt:        8. juni 1999 16:24
> > > Til:  'debian user'
> > > Emne: Short newbie question
> > >
> > > Hi Debians
> > > Whats the "partition's block device name"?
> > > I'm trying to install Debian from the dos-partition using dselect.
> > > I copied alle the files from the ftp(main, etc.)-archives and put them
> > > into the dos partition.
> > > I believe Linux should be able to "see" the dos-part., but I don't
> know
> > > the path to it in linux-speak. (It worked fine a week ago, in my first
> > > attempt, but that was only the "base" system).
> > > I tried putting /dev/hda1/ but got the error: /dev/hda1/ is not a
> block
> > > device.
> > > What am I doing wrong? (Yes I did check the "Installing debian
> gnu/Linux"
> > > manual, but found only basic inst. info., which I am getting familiar
> > > with...)
> > > Regards
> > > Vitux
> > >
> > > "Error is human; complete disaster takes a computer."
> Since it worked before during a base install, I about half-wonder if that
> partition
> didn't get clobbered somehow during that base install. Can you still boot
> into
> DOS/Windows okay? If so, then the partition is still fine. If not, then
> perhaps you
> need to verify that you are using the correct specification.
> To do this, get to a VT screen (if you're in the installer program, you
> can press
> Ctrl-Alt-F2 to switch to the second virtual terminal). Then run cfdisk (or
> fdisk for
> a more cryptic version); this program will show you what partitions you
> have where
> (you've already run this once during the base install, so it should look
> familiar).
> If everything looks fine, you might try mounting the partition manually.
> Again, from
> a virtual terminal, as root, type something like this: "mount -t vfat
> /dev/hda1
> /drivec"
> You'll need to use whatever cfdisk showed as your dos partition in place
> of the
> "/dev/hda1", and the "/drivec" directory must already exist. If not, you
> can create
> it with "mkdir /drivec". (Alternatively, use "/mnt" instead of "/drivec";
> it probably
> already exists.)
> One final idea; do an "ls -l /dev/hd* | more" command. This will list all
> the
> hd* items in the /dev directory. You should see one named /dev/hda1 (or
> whatever your
> dos partition is on) and the first character on the line should be a "b"
> (next to the
> "rw-r-----" type stuff, which means it's a block device; c means it's a
> character
> device, etc). If it's missing or doesn't have the "b", report it to this
> list so the
> more experienced folks can help you out.

Reply to: