[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

fetchmail over ssh, how?

I am trying to run fetchmail over ssh but I seem to be too dumb to get it
going. Ive read the (debian) docs, a webpage dedicated to this problem 
(http://yosh.gimp.org/Secure-POP-SSH.html) but still I cant get it going. 
I hope somebody here can help me.

The setup, two debian/slink boxes ap031 and ap058. I am on ap031, ssh-agent,
ssh-askpass(?) are running, so that I can log into the other machine simply
with ssh (seems not to apply here...). I want to get mail from ap058. ssh is
installed on both machines, username both times cts, authorized_keys entries
are ok.

My entry in .fetchmailrc;
poll ap058 port 11110 via localhost with protocol pop3:
        preconnect "ssh -C -f cts@ap058 -L 11110:ap058:110 sleep 5"
#       password foobar;
When I run the preconnect command alone I can telnet localhost 11110 and get
a connections
Is password needed? If I enter something there I am not asked for a
password, but I am unsure _which_ password I have to give (and why). Is it
really the password on ap058 or the pgp passphrase on ap031? Or vice versa?
All four paswords differ... I think I have tried them all.

 Enter password for cts@ap058: 
 fetchmail: 4.6.4 querying ap058 (protocol POP3) at Tue Jun  8 16:35:32 1999
 fwd connect from localhost to local port sshdfwd-11110
 fetchmail: socket error while fetching from ap058
 fetchmail: Query status=2
 fetchmail: normal termination, status 2

No mail is fetched, but even if none would be fetched I should get a "no
mail" message like I get without ssh? What does the socket error mean?

Another try:
 Enter password for cts@ap058: 
 fetchmail: 4.6.4 querying ap058 (protocol POP3) at Tue Jun  8 16:37:54 1999
 Local: bind: Address already in use
 fetchmail: pre-connection command failed with status 65280
 fetchmail: Query status=5
 fetchmail: normal termination, status 5

This means that the port address I want to use is allready in use? How can I
reuse that port again?

I changed the preconnect to
 preconnect "ssh-agent ssh -f -L 11110:ap058:110 ap058 sleep 20 </dev/null >/dev/null";
so that I have to enter my local passphrase and if I enter a wrong one, I
have to enter the remote password, good. But still I get the socket error
message. What am I doing wrong?


Reply to: