[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

can't login after package installation

I tried to install TCL on my machine (hamm) but had to install first
libreadline and libncurses. I made a fault and tried to install first
libreadline (with dpkg) the package complained that libncurses are required

After this installation attempt I wasn't able to login anymore (with
telnet). The login processes finishes before the prompt is displayed with 
the following error message:

  You have mail.
  -bash: error in loading shared libraries: libncurses.so.4: cannot open
  shared object file: No such file or directory

Since I can't login I  cannot install libncurses or remove libreadline :[
There seems to be a bug in the libreadline debian package. If some other
package is required first the package shouldn't make any changes to the

I didn't tried to login on the console yet since the machine is remote but
I suspect the login process will also kick me out. Could someone give me
a hint how to fix this this problem? I only have a boot disk (prepared by 
copying the kernel) and the debian rescue disk. I suspect I need a real
boot disk with an own root file system on it.


Reply to: